Zoom in/out not working when using 3Dviewer

Hi! Zoom function from the FIJI console seems don’t work correctly on the active 3D Viewer windows. I’ve tried mouse scroll, +/- and arrows but the volume stays at the same position. I’ve used FIJI with java 6 (java 3D 1.5.2) and java 8 (java3D 1.6) and loaded stacks not bigger than 50 slices from microCT images… I’d to know the problem is related to the image or to the general configuration of FIJI in my pc. Thanks in advance.


For me, the zoom is working for the 3D Viewer. My setup is: ImageJ 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit] - I’m on a Mac though.

How about testing the T1 Head Sample that comes with Fiji? Just go to File > Open Samples > T1 Head (2.4M, 16-bits). Convert it to an 8-bit image via Image > Type > 8-bit. Then open the viewer with Plugins > 3D Viewer … change the Resampling Factor to 1. Try zooming on this sample to see if it works for you.

Then we can at least see if it your image or your Fiji setup - perhaps?? Unless someone else here on the Forum has some better insight…


Thank you! I tested the 3Dviewer with the T1 Head open sample, but zoom still not working. I’m afraid there is a problem with the setup. In fact, it seems to show a volume, but it is too large for the window size. To enlarge the windows don’t change the proportions. I would need to zoom out to visualize the entire volume… or perhaps there are another way?


Are you initially opening your datasets with Bio-Formats? If not - we recommend doing so to ensure your metadata is being read correctly… Perhaps that will help solve your issue? There are also a few other older forum posts regarding issues with 3D Viewer - perhaps reading over those and testing a few of the suggestions there will help:

Though perhaps others here on the forum can provide a more targeted solution for you.


Hi! I read the topics. I’ve recently updated the drivers of my graphic card and this could probably generate some incompatibility?? Then I download again the last version of FIJI-Java8/Java3D1.6 and 3DViewer is running correctly up to now. Thank you for help!