Zernike error on measureobjectsizeshape module in linux

Hi,
I am trying to run cellProfiler on linux without the GUI.
I use the module measureobjectssizeshape without calculating zernike features.

I get the following error:

Error detected during run of module MeasureObjectSizeShape
Traceback (most recent call last):
File “/share/apps/CellProfiler/CellProfiler/cellprofiler/pipeline.py”, line 1283, in run_with_yield
module.run(workspace)
File “/share/apps/CellProfiler/CellProfiler/cellprofiler/modules/measureobjectsizeshape.py”, line 290, in run
self.run_on_objects(object_group.name.value, workspace)
File “/share/apps/CellProfiler/CellProfiler/cellprofiler/modules/measureobjectsizeshape.py”, line 368, in run_on_objects
zf_l = cpmz.zernike(zernike_numbers, labels, indices)
File “/share/apps/CellProfiler/CellProfiler/cellprofiler/cpmath/zernike.py”, line 133, in zernike
centers,radii = minimum_enclosing_circle(labels,indexes)
File “/share/apps/CellProfiler/CellProfiler/cellprofiler/cpmath/cpmorphology.py”, line 1244, in minimum_enclosing_circle
labels_to_consider)
File “/share/apps/CellProfiler/lib/python2.6/site-packages/scipy/ndimage/measurements.py”, line 567, in minimum
return _select(input, labels, index, find_min=True)[0]
File “/share/apps/CellProfiler/lib/python2.6/site-packages/scipy/ndimage/measurements.py”, line 471, in _select
unique_labels, labels = numpy.unique1d(labels, return_inverse=True)
AttributeError: ‘module’ object has no attribute 'unique1d’
INFO:PipelineStatistics:Tue Dec 20 15:27:24 2011: Image # 1, module MeasureObjectSizeShape # 4: 12.29 sec (bg)
Tue Dec 20 15:27:24 2011: Image # 1, module MeasureObjectSizeShape # 4: 12.29 sec (bg)

I don’t get the error when I rum on windows, only when I run on linux.
please help me to figure out what’s wrong.

Thank you,
Roni

Your version of numpy may be too old; unique1d was removed with version 1.6. Try upgrading your installation of numpy and see if that fixes the problem.

Regards,
-Mark

Hi Mark,
Thank you for the replay,
I installed version 1.6 and I still get the same error.
Please let me know if there is anything else I can do about it.
Thanks,
Roni

In that case, upgrading scipy may work. I run 0.9.0 and don’t get this error.
-Mark