Wrong metadata type: TEXT instead of float

I have imported data from http://cellprofiler.org/linked_files/TranslocationData.zip and extracted metadata from the file Translocation_doses_and_controls.csv.
After running the CP2.1 pipeline I opened the DefaultDB.properties in CP Analyst. When I created a scatterplot of metadata_Dose vs image_number the x-axis scale was strange.


Then I checked the database and found out that the field Image_Metadata_Dose field was of type ‘TEXT’ instead of ‘float’. Changing this in the database gives a correct x-axis scale.

My guess is that this problem has something to do with the Swedish numerical settings on my computer, using ‘,’ as decimal Point.

In CP 2.1, you have the option of setting the metadata type upon importing a CSV of values. Look for the “Metadata data type” setting, which appears at the bottom if you are using CSV importing in conjunction with another metadata source (e.g., from file/paths). There, if you select “Choose for each”, you can specify the metadata types individually, with ‘Text’ as the default.
-Mark

Perfect! Thanks, Mark.