Windows installation failed due to error in installing build dependencies

Hello -
I’m trying to install napari for the first time on my system and am running into some issues with Python 3 (3.8.2). I’ve tried installing via pip

OS: Windows 10

Please find the error log.
error dump.txt (475.5 KB)

The issue is that the current release version of vispy, a dependency of napari, does not officially support Python 3.8. There are no binary wheels on PyPI and to build it from source you need https://github.com/vispy/vispy/pull/1799.

Possible workarounds: install vispy manually from https://www.lfd.uci.edu/~gohlke/pythonlibs/#vispy or use Anaconda/conda-forge.

2 Likes

I installed vispy through its source repository, and then retried installing napari which ran successfully.

Thanks

1 Like