Will ImageJ open NEF format

Hello, we saved pictures as NEF to keep as much information as possible with our Nikon camera. But when I open NEF picture using ImageJ, it became very small. Right now, I used another software to convert NEF to Tiff before I do analysis via ImageJ. Is there a way to directly convert the picture in ImageJ?

Thanks in advance.

Try using the Fiji distribution of ImageJ with the Bio-Formats plugin. File :arrow_forward: Import :arrow_forward: Bio-Formats. If the NEF is still very small, you can report an issue to the Bio-Formats team.

1 Like

Hello ctrueden,

Thank you for sharing. I tried the Bio-Formats plugin, the size is much bigger, but I can’t see any cells. On the contrary, it worked if I just opened the NEF picture via Preview. (Left: picture opened via Bio-Formats plugin, middle: picture opened directly in ImageJ, right: picture opened via Preview).

Your raw data is 16-bit. Did you check the Autoscale option?

See: The image I loaded is displayed all black! But it is not black!

Hi, I tried the trick, but it didn’t do anything when I hit the auto button. And I don’t know why it displayed three pictures as a stack when I opened my NEF picture using the plugin.

Did you mouse over your image, checking the data values in the status bar, as suggested by the page I linked? Are your data values actually 0, or non-zero? If non-zero, it should be possible to adjust the brightness/contrast (shift+C) in order to see an image which is not all black.

NEF pictures are in color, meaning they have red, green and blue color channels. Bio-Formats will open these as image stacks with three channels (should see a C slider with three positions). Each channel can have a separate color lookup table, allowing you to customize the colorization of the image.

When I opened my NEF file, the data values are 0. I wasn’t sure if my setting is right, but I still didn’t see anything on my picture. For some reason, the picture I opened via this way is slightly bigger than the one after I converted to tif format. (6036x4020 vs. 6000x4000). Thank you for your time and help.


There is no setting in Bio-Formats which will fix that… it is simply failing to read the pixel values properly. You are able to read the file in other software, and it shows non-zero values, correct? If so, you should report a bug to the Bio-Formats team.