Why can I no longer open 2dseq files?



In order to install and NTFS driver to fix an issue with saving to a backup disk, I recently updated my Mac’s OS to the most current version. The problem with saving is fixed, but now I can’t open 2dseq files.

I downloaded both BrukerOpener.jar and HandleExtraFileTypes.class again and put them in my applications folder, but nothing changed. (I’m also unable to actually open those files, but that wasn’t a problem when I installed them the first time. Somehow it just worked.)

I am rather lost and confused. Does anybody know how I might fix this issue?


(Also I’m using Fiji, if that helps.)



Can you be a bit more specific with where/how you tried to install this plugin - Import Bruker NMR Files?

According to their website, they say how/where to install it: “Download BrukerOpener.jar to the plugins folder, or subfolder, restart ImageJ, then open Bruker files using File/Open or drag and drop.”

And be sure you also install the other one HandleExtraFileTypes.class the same way - as they say “Download HandleExtraFileTypes.class to the plugins folder, or a subfolder of the plugins folder.”



The trouble is that I’m using a Mac and as far as I know, I don’t actually have a plugins folder.

So I downloaded both of those and just put them in my applications folder. I also changed the security settings in my system preferences to allow both apps. As far as I can remember, that’s all I did.



If you go to your Applications folder… Just right-click on the Fiji icon and click on Show Package Contents.

Then you should see the ‘plugins’ folder where you can put those necessary files.

eta :slight_smile:


I successfully moved the files into the plugins folder, but unfortunately it’s still not working. If it helps, this is the error message that pops up when I try to open a 2dseq file:




Have you tried opening different files to be sure this is happening consistently and not just a corrupted file? Can you attach the original file you are trying to open then?

If you cannot attach an image here directly in this forum thread - provide a link to share it with us. Otherwise - we cannot fully reproduce/test the error you are seeing…



I have tried opening different 2dseq files from the same disk (an easystore), and the error happens consistently. How could I tell if a file has been corrupted?

I just tried to upload one of the 2dseq files here, but this error popped up so I’m assuming it isn’t possible:


I’m sorry that I’m not entirely sure what other kind of image would be helpful, so for now I’ll just try to add extra information. For example, I know that I can open every file on this list except the 2dseq:



If you’ve tried opening multiple files… then there is some other issue besides a single, weird file. Let’s see.

I would need the same exact file type you are trying to open to test… you can share it via any file-sharing site like Dropbox, etc.

But really - you perhaps need to contact Bruker to see… since this is their proprietary image format. I had invited the author of the plugin to this thread - but no response yet… perhaps it’s worth emailing him directly as well? Bertram Manz (bertram.manz@ibmt.fraunhofer.de)



One solution is to compress files as a .zip and attach that. Another is to use a cloud-sharing service such as Dropbox, as @etarena suggested.