Where's runImageJ module?

hi, i’ve recently installed CellProfiler on Ubuntu 14.04 by following source install instruction so I assume i’m running the most recent version. then I’ve tried hard to count positively stained cells from IHC images and finally realized that IHC profiler plugin in ImageJ works just best. the problem is that I still need to stick to CellProfiler, 'cause there are other functionalities that ImageJ does not support.

so I think the best option is to use runImageJ module to utilize the plugin, but I cannot find the module in my CellProfiler. what should I do?


When you add a new module, can you find “RunImageJ” under the parent group “Image processing” ? It’s supposed to be there.

RunImageJ has been deprecated- see here for more details. Sorry!

1 Like

thanks for the reply. then could you recommend the best option i can choose? it seems like the thread you linked discourages me from downgrading CP to get runImageJ module back…

It depends on your workflow whether downgrading CP to get that back vs breaking your workflow into steps (an ImageJ step, then a CP step) is easier; without knowing more, it’s hard to say.

thanks for kind reply. so I decided and have tried to downgrade, but ended up in a terrible disaster…

in order to downgrade to 2.2.0, I executed the following commands according to the source installation guide.

rm -fr /opt/CellProfiler
rm -fr /usr/local/bin/cellprofiler
rm -fr /usr/lib/python2.7/dist-packages/*

and then

sudo git checkout 2.2.0
sudo pip install --editable . --process-dependency-links
sudo pip uninstall prokaryote
sudo pip install prokaryote
sudo pip install javabridge

and then when I try python Cellprofiler.py, it says…

File “/opt/CellProfiler/cellprofiler/preferences.py”, line 111, in get_config
import wx
ImportError: No module named wx

what drives me crazy is that the same message appears after I reinstalled the stable release (3.0.0)!!! so now I can’t run CellProfiler anymore.

what should I do now? I think something went wrong because of the ‘rm -fr /usr/lib/python2.7/dist-packages/*’ command but don’t know what to do…

Have you tried to re-install wxPython ?
If yes, would you see it when you do:
pip freeze

(Although I suspect you don’t need to reinstall it, just need to correct its path)

Hi, i somehow installed wxPython… I think. i can see following stuffs by doing pip freeze:


now instead of “import error: no module named wx”, I get the following error message.

Traceback (most recent call last):
File “CellProfiler.py”, line 4, in
File “/opt/CellProfiler/cellprofiler/main.py”, line 110, in main
File “/opt/CellProfiler/cellprofiler/utilities/cpjvm.py”, line 95, in cp_start_vm
heap_size = str(cellprofiler.preferences.get_jvm_heap_mb()) + "m"
File “/opt/CellProfiler/cellprofiler/preferences.py”, line 1396, in get_jvm_heap_mb
if config_exists(JVM_HEAP_MB):
File “/opt/CellProfiler/cellprofiler/preferences.py”, line 237, in config_exists
if not get_config().Exists(key):
File “/opt/CellProfiler/cellprofiler/preferences.py”, line 119, in get_config
AttributeError: ‘module’ object has no attribute ‘CONFIG_USE_LOCAL_FILE’

Hm it seems to be similar to this issue

You could find at least 2 solutions there:

  • (a bit more properly) installation of wxPython
  • Or using conda installation, introduced by Kyle
1 Like

thank you so much. you’re my life saver!

1 Like