Weka Plugin issues

fiji

#1

I recently installed Weka in order to use the weka trainable segmenter plugin in fiji but have not been able to get the segmenter to operate. I keep receiving the following message…

(Fiji Is Just) ImageJ 2.0.0-rc-43/1.52i; Java 1.6.0_24 [64-bit]; Windows 7 6.1
 
java.lang.NoClassDefFoundError: org/pentaho/packageManagement/PackageManager
	at weka.core.WekaPackageManager.<clinit>(WekaPackageManager.java:99)
	at weka.gui.GenericObjectEditor.determineClasses(GenericObjectEditor.java:177)
	at weka.gui.GenericObjectEditor.<clinit>(GenericObjectEditor.java:247)
	at sun.misc.Unsafe.ensureClassInitialized(Native Method)
	at sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(UnsafeFieldAccessorFactory.java:25)
	at sun.reflect.ReflectionFactory.newFieldAccessor(ReflectionFactory.java:122)
	at java.lang.reflect.Field.acquireFieldAccessor(Field.java:918)
	at java.lang.reflect.Field.getFieldAccessor(Field.java:899)
	at java.lang.reflect.Field.get(Field.java:358)

I am not sure how to resolve the situation


#2

@lencarn

So… I’m not sure the exact issue here. Perhaps @iarganda will know better given the stack trace you show above…

But - I do know that Trainable Weka Segmentation (TWS) comes with Fiji already built-in. So there should be no need to download this tool for manual installation. What exactly did you install in your case and where?

I would just try a clean installation of Fiji - just download and install it again. Search for the TWS plugin… and see if it’s then working for you.

eta


#3

Exactly, that should be easiest fix.