WebcamCapture Plugin

imagej

#1

Hello togheter,

i wont integrate an DirectShow possible working Camera, they works under Skype and DxFilterTools.
When i try to open this Plugin (from pluginlist of ImageJ) , ImageJ emit following Errors:

ImageJ 1.50i; Java 1.6.0_20 [32-bit]; Windows NT (unknown) 6.2; 2589K of 640MB (<1%)
com.github.sarxos.webcam.WebcamException: Cannot execute task
	at com.github.sarxos.webcam.WebcamProcessor$AtomicProcessor.process(WebcamProcessor.java:57)
	at com.github.sarxos.webcam.WebcamProcessor.process(WebcamProcessor.java:120)
	at com.github.sarxos.webcam.WebcamTask.process(WebcamTask.java:35)
	at com.github.sarxos.webcam.ds.cgt.WebcamOpenTask.open(WebcamOpenTask.java:20)
	at com.github.sarxos.webcam.Webcam.open(Webcam.java:187)
	at com.github.sarxos.webcam.Webcam.open(Webcam.java:147)
	at IJ_webcam_plugin.run(IJ_webcam_plugin.java:86)
	at ij.IJ.runUserPlugIn(IJ.java:216)
	at ij.IJ.runPlugIn(IJ.java:180)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:619)
Caused by: com.github.sarxos.webcam.WebcamException: Cannot start native grabber!
	at com.github.sarxos.webcam.ds.buildin.WebcamDefaultDevice.open(WebcamDefaultDevice.java:220)
	at com.github.sarxos.webcam.ds.cgt.WebcamOpenTask.handle(WebcamOpenTask.java:38)
	at com.github.sarxos.webcam.WebcamProcessor$AtomicProcessor.run(WebcamProcessor.java:66)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	... 1 more

I am happy for any suggestions.
Thx
Karsten from Berlin
www.FlexxVision.de


#2

Do you mean this plugin:

https://imagej.nih.gov/ij/plugins/webcam-capture/index.html

It uses the sarxos webcam capture library:

http://webcam-capture.sarxos.pl/

The caught exception "Caused by: com.github.sarxos.webcam.WebcamException: Cannot start native grabber!"
indicates that the camera device can’t be accesed.

Possibly the webcam is already occupied from another application.

Try to close all software which is using the camera and then try again.

Another possibility is to update the embedded plugins sarxos webcam lib and see if it then works.

But probably the author of the plugin can give you a better help if all that doesn’t work (see contact).