Watershed Error in 3D

Hello,
I tried to analysis 3D z-stack images.
I can run Watershed on the color images. But when I changed the color of the same images to gray, the error message as below popped up. Why? Is there a solution for this?
Thank you

WatershedError

Welcome!

Do you mind posting your pipeline? My guess is that it’s a simple configuration issue.

Hello Anne,
Thank you so much for the response.
Here are the pipelines I used. Pretty simple actually.
Test3D2019Jun2grey.cppipe (8.3 KB) Test3D2019Jun2color.cppipe (8.3 KB)

Today I found another interesting things as the figures below. I tried to clicked open the images. And then the following things happened.

Left window was processed as 3D in the NamesAndTypes. Right window was the same image not processed as 3D in the NamesAndTypes. I don’t know why…


Hm, I’m stumped! Hope someone else can help. Your results where a full image is not shown when you pick 3D makes me wonder if your images are not actually 3D. It would be easier to diagnose if you could include an example image.

In general, I can at least say that if you decide NOT to treat an incoming z-stack as 3D in NamesAndTypes, you are instead telling CellProfiler to handle each individual slice as a separate entity through the pipeline. It sounds like you don’t want to do that.

Hi Anne, the above image is an example. It’s one of the over 100 optical slides of the Z-stacks of a 3D spheroid, exported using Zen software as Tiff. The green/white dots were nuclei staining. I need to count the number of the nuclei in 3D…

I am a bit disappointed that IdentifyPrimaryObjects in CellProfiler doesn’t support 3D :frowning:

I don’t see an image file, only screenshots? I think there’s something wrong with how the file is interacting with your configuration settings in the first 4 modules.

You & me both wish IdentifyPrimaryObjects worked in 3D! :smiley: It would have taken months of extra software engineer time to make that work.