Velleman k8061 driver

We would like to use the velleman k8061 with micro-manager to have a Laser Diode control for custom-build super-resolution microscopes. We already wrote an implementation for the k8061 for Linux, using the comedi driver.
For Windows, we’d like to rely on Nico Stuurmans work:

https://micro-manager.org/wiki/Velleman_K8061

However, I have some trouble installing the driver that I downloaded from your page:
valelab.ucsf.edu/~MM/drivers/K8061Driver.zip

After unpacking and clicking on the installer_x64, I’d expect some GUI to pop up, but instead nothing happens. Also, it won’t be recognized in micro-managers wizard.

Thank you very much,

Daniel

Did you find @Austin_ARC’s excellent instruction: http://www.austinblanco.com/Resources/How%20to%20install%20a%20Velleman%20board%20on%20umanager.pdf ?

Yes, but I couldn’t find the C:\Program Files\Micro-Manager-1.3\drivers path that Austin described in #4, when I tried to reproduce it in my 2.0 gamma nightly build version.

Ah yes. Micro-Manager-specific drivers were placed in their own github repository: GitHub - micro-manager/MMDrivers: Drivers

I downloaded the drivers from github, then after plugging in the device I went to the Device-manager, right clicked on properties → update driver → browse my computer for drivers, picked the K8061 main folder and got the message “Windows could not find drivers for your device”

Windows states that this is a Microsoft Windows 10 Pro, Version 10.0.19042 installation.

I have not worked with a K8061 for many, many years, and I am afraid that you are a bit on your own figuring out to get this old hardware to work. I am quite sure that Windows 10 requires drivers to be signed (which these are not), and I vaguely remember that you need to tell your OS explicitly to allow installation of unsigned drivers (for instance, see: How to Install Unsigned Drivers in Windows 10 : Online Support Center). One other thing to check is that the VID and PID (you should be able to find those through the Device Manager) match those in the .inf file in the K8061 drivers folder.

Dear Nico,

I’m a collegue of Daniel and I’ve been trying to make the K8061 working with our setup. Up to this point I have done the following steps:

  • took the DLL and SYS files and packed them into a new installer (using AMD64 architecture);
  • tried to update K8061 driver using the .inf file which was inside the repo you linked before.

When doing the second step (which is the same that Daniel tried out) I don’t get the unsigned driver error you mentioned earlier, but instead I only get “A general error occurred”. Now I’m not much an expert of Windows drivers but I wanted to ask if there was any source code used to build these drivers, just to see if building one from scratch could solve the issue. I also did not try the aforementioned suggestion concerning how to install unsigned drivers in Windows 10 because the error which is shown in the link does not pop-up to us.

Thanks,

Jacopo

If I remember correctly, these are libusb drivers. LibUSB-win32 used to include a utility to create these drivers that only needed the VID and PID as input. You can see if that still works (we have not updated these driver in about 10 years, and quite a bit may chave changed in the interim). I would start at libusb-win32 / Wiki / Home