Value error with data type

cellprofiler

#1

I’m trying to segment nuclei in images of an organoid. I’ve simplified one of your example pipelines to do this, but I’m getting the following error when I try to run the pipeline. Is there some sort of transformation/conversion I should apply to the images to make them readable? 45 PM

I’ve attached the pipeline and some example images.

CellProfiler.zip (8.0 MB)


#2

Hi, @Lauren_Beck!

CellProfiler expects three-dimensional data to be stored as a multi-page TIFF. Either you can combine your slices into one TIFF or you can process the image in two-dimensions (e.g. disabling the Process as volume setting in the NamesAndTypes module fixes your problem).


#3

Hmm, I’m actually getting the same error when I run the pipeline on a z-stack TIFF.


#4

@Lauren_Beck Unfortunately, IdentifyPrimaryObjects only works for two-dimensional images. You would need to use the Watershed module from the Advanced category to segment your z-stack.


#5

It might make sense for you to start with the 3D example pipeline (is it on the examples page, I imagine?)


#6

Yes, the 3D example pipeline and details are explained here: https://github.com/CellProfiler/tutorials/tree/master/3d_monolayer