Upload update site failed

Hi, I can’t upload ot my update site ndef-auto anymore. I’ve got the following error message:
http://sites.imagej.net/Ndef-auto/ does not exist yet!”

java.io.IOException: Server returned HTTP response code: 500 for URL: http://sites.imagej.net/Ndef-auto//
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1436)
	at net.imagej.plugins.uploaders.webdav.WebDAVUploader.directoryExists(WebDAVUploader.java:392)
	at net.imagej.plugins.uploaders.webdav.WebDAVUploader.login(WebDAVUploader.java:159)
	at net.imagej.updater.FilesUploader.login(FilesUploader.java:410)
	at net.imagej.ui.swing.updater.UpdaterFrame.upload(UpdaterFrame.java:803)
	at net.imagej.ui.swing.updater.UpdaterFrame$5$1.run(UpdaterFrame.java:311)
[ERROR] http://sites.imagej.net/Ndef-auto/ does not exist yet!

However, it DOES exist:
http://sites.imagej.net/Ndef-auto/

I’ve tried to change my password using this site but it failed.

Any ideas?

Best,
Thorsten

I posted the same error here with the Java-8 update site. Maybe @ctrueden has some ideas?

thanks for the info. I tried to search the forum for such errors to avoid double posting, but I guess I failed… Good to know that I’m not the only one having this problem though.

1 Like

Sorry for the delay in reply; I somehow missed this post till now. Anyway, I fixed this problem earlier today! All should be OK now; let me know if not.

1 Like

It is not working for me. I just tried to upload to the java8 update site and I keep getting this prompt in an infinite loop no matter what I type in (AFAICT, my credentials are OK):

For me it works! Thanks!

1 Like

that works for me too. thanks.

1 Like

The dialog in your screenshot means your credentials are not correct.

And then after 10 failed attempts, the system temporarily bans you.

Normally, this is where I would ask you to reset your password. But the password changing page is temporarily non-functional, while we shore up security weaknesses.

@aneevel The community critically needs this—please get it back up and running ASAP.

Hi all,

I’ve made some changes to the password changing function in order to address some security weaknesses; you should now all be able to change your passwords, just as before.

I have already done some testing to ensure all is well, but additional testing is also appreciated. @tferr I know you in particular need to authenticate; would you let me know how a password change and authentication attempt go for you?

3 Likes

@aneevel All is good now. Thanks!

2 Likes