Updating jgrapht-0.8.3.jar to a newer version?

fiji
imagej
trackmate

#21

Unfortunately, your recent commit messed up the pom.xml:

The versions of commons-io and poi are now managed with pom-scijava-24.2.0, so you shouldn’t be overriding them in your own POM anymore.

Also, I recommend using SNAPSHOT versions on the master branch, and only put release versions on tags using release-version.sh to ensure reproducible builds.


#22

Hi, I removed the pom conflicts and used a SNAPSHOT version on the master branch. I am not sure how to run the release version script though to get a reproducible build from the SNAPSHOT version though.


#23

#24

Hi all

On my side I checked all the TrackMate-depending projects and have PRs ready.
So when I get your go we can update JGraphT in the parent pom and release all these dependencies.
I will be waiting on your signal.


#25

@tinevez I would like to release pom-scijava 25.0.0 with the update to JGraphT 1.3.0 along with preemptive bumps of all affected plugins. That way, each dependency can update its parent to pom-scijava 25.0.0 and leave off the jgrapht version property, make the API changes you have already done, merge to master, and release, without any snapshot couplings.

Do you like that plan? If so, please give me a list of all affected components, and their new to-be-released version numbers, and I will bump them all accordingly in pom-scijava and release 25.0.0 for you ASAP.


#26
  • TrackMate
  • MaMuT
  • TrackMate-TrackAnalysis
  • trackmate-ops (might have to talk to @dietzc about this)
  • TrackMate-examples
  • trackmate-core

For version numbers, I kindly ask for a bit more time as I am attending the NEUBIAS conf.
The other developers are ok? @kapoorlab


#27

If you like, I can take care of checking for you right now. Would that make your life easier? Then we’d get pom-scijava out the door sooner, and ready for you as soon as you have time.


#28

Awesome! Yes thanks but do YOU have the time?


#29

For you, @tinevez, I do! :blush:

None of these are managed by pom-scijava right now, so no need to worry about them as part of the new pom-scijava release. They can all get their respective updates finalized at your leisure.

With scijava/pom-scijava@895c1c18, JGraphT has been updated to 1.3.0, with all jgrapht-* artifacts now managed, and TrackMate preemptively bumped to 4.0.0.

I also cut the release of pom-scijava 25.0.0, which Travis CI should deploy within the next few minutes, and which should become available from Maven Central within the next hour. Next steps after that:

  1. Update TrackMate update-jgrapht branch to extend pom-scijava 25.0.0 and remove the pinned jgrapht.version and <version>${jgrapht.version}</version> lines, in favor of default jgrapht component version management.
  2. Build and test TrackMate; ensure everything looks good.
  3. Cut the release of TrackMate using release-version.sh.
  4. Update downstream components requiring TrackMate to also extend pom-scijava 25.0.0, ensure they all work, and merge their respective update-jgrapht branches to master.
  5. :moneybag:

#30

@tinevez net.sf.jgrapht does not work for me, so I have to keep org.jgrapht in the pom while using pom/scijava version 24.2.0.


#31

The current JGraphT 1.3.0 has a groupId of org.jgrapht. The groupId of net.sf.jgrapht is obsolete. So you should be using org.jgrapht in your POM.

@kapoorlab Please try updating your project to use pom-scijava 25.0.0!


#32

Please note that the PR linked in my post above did all this already for you:

The only thing that changed since then is that you can now depend on pom-scijava
version 25.0.0 as stated by @ctrueden, and can omit the <property> definition for the jgrapht version.


#33

@imagejan, Ah right sorry, I got confused looking at the pom of Trackmate (https://github.com/fiji/TrackMate/blob/master/pom.xml). It still uses net.sf.jgrapht with scijava-24.2.0.

I tried to change the pom-scijava to 25.0.0 but am unable to transfer scijava-25.0.0 @ctrueden , I tried it with ethernet (with firewall) and with wifi (no firewall), so will have to try this from home wifi.

Project build error: Non-resolvable parent POM for net.kapoor:MTV_Tracker:2.0.5-SNAPSHOT: Failure to transfer org.scijava:pom-scijava:pom:25.0.0 from http://maven.imagej.net/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of imagej.public has elapsed or updates are forced. Original error: Could not
org.scijava:pom-scijava:pom:25.0.0 from/to imagej.public (http://maven.imagej.net/content/groups/public): connect timed out and 'parent.relativePath' points at no local POM


#34

Maybe your firewall blocked access the first time, and after that, the failure is cached for 24 hours. You can pass the -U flag to mvn to force an immediate retry, instead of waiting.


#35

@tinevez TrackMate 4.0.0 is released, and the following PRs should be good to merge:


#36

Merged but one.
Luxemboug is such a nice city.


#37

@ctrueden, the problem is that in my terminal even after I export proper https and http setting I am unable to ping websites and get stuff downloaded from maven.imagej.net also. I am using Iterm2 terminal, I will try with other terminal and see if it can be resolved by that. For now I get this:

u934-bdd-0-52-6887:MTrack aimachine$ export http_proxy="www-cache.curie.fr:3128"
u934-bdd-0-52-6887:MTrack aimachine$ echo "$http_proxy"
www-cache.curie.fr:3128
u934-bdd-0-52-6887:MTrack aimachine$ ping www.facebook.com
PING star-mini.c10r.facebook.com (157.240.21.35): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
^C
--- star-mini.c10r.facebook.com ping statistics ---
5 packets transmitted, 0 packets received, 100.0% packet loss
u934-bdd-0-52-6887:MTrack aimachine$ pwsd
-bash: pwsd: command not found
u934-bdd-0-52-6887:MTrack aimachine$ pwd
/Users/aimachine/MTrack
u934-bdd-0-52-6887:MTrack aimachine$ mvn clean install -U
-bash: mvn: command not found
u934-bdd-0-52-6887:MTrack aimachine$ conda activate imagej
(imagej) u934-bdd-0-52-6887:MTrack aimachine$ mvn clean install -U
[INFO] Scanning for projects...
Downloading from imagej.public: http://maven.imagej.net/content/groups/public/org/scijava/pom-scijava/25.0.0/pom-scijava-25.0.0.pom
Downloading from central: https://repo.maven.apache.org/maven2/org/scijava/pom-scijava/25.0.0/pom-scijava-25.0.0.pom



#38

Hi all,
you are really awesome! :smiley: Fantastic to see that the dependency was updated so quick, great! Thanks a lot to all of you!


#39

Highly unlikely. Sounds like a problem with your proxy settings. Talk to your network admin.


#40

@bimoelle Earlier today, I uploaded the new JGraphT 1.3.0 along with TrackMate 4.0.0 to the update site. You should be good to go with uploading your new plugin on its own update site, without conflicts, assuming your plugin works with JGraphT 1.3.0. Please ping back here with any issues!