Unable to open .lif files in ImageJ

imagej

#1

Hi all,

I am having trouble opening .lif files in ImageJ. It used to work fine for me but lately some images simply do not open.
I get the error in the image attached saying that the file is not in a supported format. I have updated my ImageJ and also installed Bio-Formats plugin as I used to do before.

Very frustrating since it doesn’t seem to be a reported issue. Can anyone help/ point me in the right direction? I am working on a Mac running OS High Sierra v10.13.6

Thanks in advance
Navneet


#2

Good day,

just a very basic idea:
Did you try to change the file name to something more conventional, such as
“mySuperMicroscope-Image.lif”

If this isn’t the problem, please contact the BioFormats specialists.

Regards

Herbie


#3

Hi Herbie,

Thanks, I tried changing the file name to abc.lif and it still had an error.

I then tried to look for Bio-Formats so that I could manually try to open to the file which is when it told me about the Path Randomisation error in OS High Sierra.
I should’ve read the installation notes more closely.

The problem is now fixed but I’m attaching the bit about how to properly install ImageJ for those who might have similar issues.

Thanks!


#4

Hi all,

I had exactly the same error message, for some .lif files only, not all of them.
So I am sharing my hypothesis about it as it is a different cause.

My config: Windows 7 Pro x64, software installed in C:/
After trying this:

  • ImageJ, freshly downloaded (v1.52a) then updated to v1.52k, java 1.8.0_112
  • ImageJ v1.52j
  • Fiji, freshly downloaded (v2.0.0-rc-69 / v1.52i), java 1.8.0_172
    (Tested Bio-Formats packages: 5.8.2 and freshly downloaded 5.9.2)

Then I remembered that all the .lif files were coming from a usb stick, that “passed away”.
So I believe that corrupted files would lead to this error message?

PS: My lif files have been already successfully opened in the past, but before being copied on the faulty usb stick.