Unable to load any pipeline (even the examples provided on your wbesite)

cellprofiler

#1

Good morning,

I really like your program, it is very usefull! however, I have been having some problems starting using the program. I am unable to load any of the pipelines (the ones from the examples on your website and the ones my collegues send me). Every time i try to load, the system does not find the pipeline that is in the specified folder. Also this error appears "Subversion revision: 10211
Exception fetching new version information from http://cellprofiler.org/CPupdate.html: HTTP Error 404: Not Found C:\Program Files\CellProfiler\library.zip\cellprofiler\gui\pipelinecontroller.py:642: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
Traceback (most recent call last): socket.gaierror: [Errno 11001] getaddrinfo failed"
So I am unable to start using your program, do you think you can help me with this problem?
Thank you in advance,


#2

Hi,

Can you give us some more information? What is your OS (it looks like Windows, but what version and what bit?), what is your version of CP, did you install an executable or from compiling the source code, etc?


#3

Hello,

My system is Windows (windows 10), 64-bit operating system, I7-4500U CPU, is this information enough?. I downloaded the pipeline from your website, pasted to a folder and once i go to that folder through the program, the files does not appear.


#4

That’s enough information about your system, thanks, but can you please let me know

  • What version of CP you’re running (1.0,2.0,2.2,3.0, etc)
  • How you installed it (from the executable, from cloning the source code, etc)
  • The link of the example pipeline that’s not working for you.

#5

My version is the v10211 (2.0 i think because i tried different versions to see if they worked on other versions). I installed it from this website : http://cellprofiler.org/previous_releases/.
I tried this pipeline: http://cellprofiler.org/examples/#PercentPositive the one for “Cell/particle counting, and scoring the percentage of stained objects”.


#6

Yeah, that’s 2.0, it’s not going to load any pipelines made in any version since (~6-7 years). CP pipelines are only forwards compatible, not backwards compatible.

Is there a reason you’re using such an old version? Can you upgrade to a newer version?


#7

Because the 3.0 version (i think is the newest) when i install it, it only appears the black screen and not the green window with the comands, so i cannot do anything. I tried different versions and only this one was able to give me the full comands of the program. Do you have any idea why this happens?


#8

Did you install the java requirements linked to on the main download page? If you think you did (or aren’t sure) can you post the results of typing java -version into the Windows Command Prompt.

Otherwise I’m not sure why it wouldn’t work for you.


#9

Yes, and i was re-directed to a page that assessed if i have the correct java version, and the website said i have., but still i am not sure because i have little knowledge in informatics.
The results were "java version "1.8.0_161"
Java™ SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot™ Client VM (build 25.161-b12, mixed mode)

C:\WINDOWS\system32>"


#10

ps: the pipeline my collegues sended me that i can’t use
is this one: LiveDead-Live.cpproj (387.1 KB)


#11

Try re-downloading and installing the “Windows x64 offline” from here, just to be on the safe side, then try to run 3.0 again- keep in mind it takes a minute after the first black window pops up for the main CP window to fully load.

With 2.0 you won’t be able to load anything that ends in “.cpproj” or “.cppipe”, only things that end it “.cp”


#12

thank you so much!! This solved the problem, the program is working and all the windows appear :slight_smile: just one last question, i was loading the pipeline and this appeared image. Can i still use this pipeline?


#13

Yes, you just may need to tune things- we have a guide for doing so here.


#14

Thank you so much for the great support!