Unable to export to database

Since a couple of months I’m encountering problems with the Export to Database module in Cellprofiler.
I am using a pipeline (attached) that I have used previously (with minor modifications) and it has always worked perfectly…
No matter the changes I apply I always get the “yellow warning sign” next to the Export to Database module. Regardless, so far CP was able to generate the properties files but recently I always end up with the error message attached and I have no properties files to use with CPA.

Thanks in advance for your help and happy new year!

Matteo
siRNA Screen TECAN171214.cpproj (151 KB)
Untitled.pdf (15.7 KB)

Would you mind posting a few d0, d1 and d02 images from a couple of wells, so I can test it out?
-Mark

Thank you for your reply,
Here’s a zip file containing 3 different sets of d0 (GFP channel= bacteria colonies inside cells), d1 (Hoechst channel= nuclei) and d2 (Cy3 channel= lysosomes) images. They correspond to 3 different fields in the same 96-wells plate well.
As I mentioned earlier, whatever option I choose from the Export to Database module (Single object table, One table per objet or Single object view) I always get the yellow warning message. As I read on this forum this is not necessarily a problem because it is “just” a warning and indeed my pipeline has always worked fine. Recently however I get the message I sent earlier and no properties files are saved in my output folder…

Best

Matteo
Archive.zip (9.98 MB)

OK, I’ve been able to recreate the error. I believe the error has to do with a very obscure bug, but you can solve it as follows:

  • In ExportToDatabase, select “Yes” for "Access CPA images via URL?"You’ll see 3 new fields appear and one of them will turn red.
  • For the “Plate metadata”, select the metadata appropriate for the plate, or select “None” if there isn’t any.

The problem is that these settings are hidden in 2.1.1 if the URL setting is set to “No”, even though they have nothing to do with each other. Since the plate metadata was incorrectly set, an error resulted. This will be fixed in the next release.

Also, the warning makes sense given the way you are exporting the objects; it’s just providing some caveats to usage in CPA. Typically, we prefer to export only those objects that are needed and no others; you can do that by select “Select…” for “Export meausrments for all objects to the database?”
-Mark

Thank you very much for your help!

Sorry for this late reply but I wanted to test the changes you suggested.
It did indeed solved the database generation problem, however when I open the database in Analyst and try to generate a plate view I get the following message:

An error occurred in the program:
DBException: ERROR: Database query failed for connection “MainThread” and failed to reconnect
Query was: "CREATE TABLE link_tables_Per_Image_Per_Lysosomes (src VARCHAR(100), dest VARCHAR(100), link VARCHAR(100), ord INTEGER)"
First exception was: attempt to write a readonly database
Second exception was: ERROR: Database query failed for connection "MainThread"
Query was: "CREATE TABLE link_tables_Per_Image_Per_Lysosomes (src VARCHAR(100), dest VARCHAR(100), link VARCHAR(100), ord INTEGER)"
Exception was: attempt to write a readonly database

Traceback (most recent call last):
File “/Applications/CPAnalyst.app/Contents/Resources/cpa.py”, line 266, in launch_plate_map_browser
File “plateviewer.pyc”, line 57, in init
File “guiutils.pyc”, line 274, in init
File “dbconnect.pyc”, line 992, in get_linkable_tables
File “dbconnect.pyc”, line 855, in do_link_tables
File “dbconnect.pyc”, line 64, in fn
File “dbconnect.pyc”, line 512, in execute

Because I also followed the suggestion of exporting only some of the measurements I took, can the error be related to this?

Thanks again

Matteo

to add to my last post: I launched another analysis on the same set of data, this time exporting ALL data into the database, and I ended up with the same problem I had in the beginning, that is, failure to export and save ANY properties files and abrupt termination of CellProfiler (after having analyzed all images, so really at the point where the program should have exported the databases…)

Thank you

Matteo