Unable to delete file from site



I am trying to update the PET-CT site. I found a jar file there which is a mistake and I want to kill it.
The instructions https://imagej.net/Update_site_FAQ#How_do_I_remove_a_file_from_my_update_site.3F
say that I should right click on the file to be deleted and set it to keep-as-is, then right click again and set to obsolete.
This would be fine if it worked.
What I find is if I right click one of the options is Uninstall which is exactly what I want.
The problem is right click does nothing.
I can left click on Status/Action and choose to keep-as-is or install.
Then if I right click my choices are only 2, no longer including the Uninstall.

Is this some sort of security issue? If so, how do I get permission to actually uninstall?
In any case, I need control over my site in order to update it properly.



@imagejan or @ctrueden or @haesleinhuepf or @stelfrich or anyone else who knows a bit more about update sites?!



Hi @ilan

I once had similar issues with the updater when my Fiji was not up to date. The issue is that it can only do one thing at once. Try updating Fiji, restart it and then try to mark this file as obsolete. And only this, no adding of other files or whatever. Just one thing at once :wink:

Does that help?



Thanks @etarena for bumping this topic.

I think these instructions might be outdated a little. When I run the updater, I can select the following options for an up-to-date file from my update site:

  • Keep as is
  • Upload to <my-update-site>
  • Mark obsolete (<my-update-site>)
  • Uninstall

Note that you only get those options when no other pending changes are active.

Mark obsolete should do the right thing for you then.


Thanks for the replies. I am still having problems.
I took the advice to have nothing pending, including my locally modified files.
The locally modified files and new things I haven’t yet updated, but I clobbered them with the Fiji site versions.
Then I hoped I would be able to get rid of my garbage files. No such luck.

There were 2 files I wanted to kill (mark as obsolete). One was dependent on the other.
I could uninstall the files, which removed them from my Fiji application.
When I exited Fiji and came back in the file which wasn’t dependent was gone.
The updated wanted me to install or keep as is, this file.
I figured that may violate the one-thing-at-a-time requirement, so I installed the dependent file, even if the mother file was not installed.
The mother file at least didn’t bother me about wanting to install it, but I had no option to make it obsolete.

In short, in no case can I get the mark obsolete options. I keep wondering if this isn’t some sort of security problem?
Maybe it wants to protect my site from someone else marking files as obsolete?
In any case, I can’t get the obsolete option to fly. I can’t take out my garbage to the dump.


I have some Local-only files which hopefully are not causing any problems.

Two of them I eventually do want to upload to my site.
Now I notice that on the local only files my only options are keep-as-is and uninstall.

Maybe I need to update ImageJ. When I click on that it gives me an option to upgrade to v1.51r.
It says I am running v1.51n. Is this OK, or is there a problem here?


You probably used Help > Update ImageJ…, which will only update ij.jar, i.e. the ImageJ 1.x component. The updater functionality is all ImageJ2.

The updater will only offer the Mark as obsolete option if you have credentials entered for at least one update site, i.e. if you are also able to upload files to that site. Also, the changes you make will only take effect after you click Apply changes (upload) to actually modify your update site.

Can you check whether you can upload a new file? If so, also the mark obsolete option should be available for already installed (up-to-date) files. If not, try applying all (current) changes first and restarting Fiji.

Alternatively, please try with a newly downloaded fresh version of Fiji, after adding your update site and entering the upload information.

If all this doesn’t help yet, maybe you can post a screenshot that might help others spotting the problem…


I just tried to set one of my files to a later version.
I am not quite ready to release this but the updater is happy to update the site for me.

The last time I committed something was a couple of weeks ago, it certainly knows who I am.

Maybe the only thing to do is start over with a totally new copy of Fiji and then see what happens.


OK I put up a totally fresh copy of Fiji and no change whatsoever.
It isn’t clear to me how to include a screen shot, but what I have is the same response.
When I click on a Local-only file, my options are keep-as-is and Uninstall.
When I click on the mother file which I uninstalled, my only options are keep-as-is and Install.

I tried an update of one of my files. That went through without any problem.

The details of what I did

  1. rename Fiji.app to Fiji_old.app
  2. download and extract to Fiji.app
    It didn’t ask me to identify myself, presumably because it knows who I am.

So I still have no obsolete and no upload of new files.


Just because I just removed a file from one of our update sites: I have uninstalled the file I wanted to delete from the update site first and only after restarting ImageJ/Fiji I got the option to mark as obsolete on the site.



Thanks for the help.
My previous Fiji.app is somehow screwed up.
On the new Fiji.app I didn’t log in correctly.
Once I correctly logged in on the new Fiji.app, things started to work correctly.