Unable to add site in updater

imagej
updater

#16

The same, no change in behavior, which is the same as @falk reports: I can change the password on the “Initialization or Change” page, but when trying to upload, I get stuch in the username/password dialog.


#17

Hi all,

I apologize for asking again, but could you please test your individual issues again? I hope this solution is able to resolve all your lingering issues!

Thanks!


#18

It worked this time. I did have to change the password again after your change (expected, but in case others don’t realize), and I am now able to upload.

Thank you!


#19

I had to change my password again but it works now.


#20

It works. Thank you very much!


#21

I also encountered this problem today, when attempting to upload to the Java-8 update site. After a couple of cycles changing my password and then failing to upload successfully, it occurred to me to try a password without symbols. When I did that, I was able to upload.

So @aneevel, my guess is that there is a bug in the script when the submitted password contains symbols, probably relating to encoding of certain characters. Or more specifically, failing to decode them before calling the password changing routine.


#22

@ctrueden, @aneevel:
yes, I have used non-alphabetical symbols in both passwords that I have tried (no accented characters though).
Today morning, the upload worked fine again (also with password with symbols), so if there were problem, it seems to be fixed.

Thanks again for your help!


#23

Thank you! password updated worked and I could upload again.


#24

Hello,

I am still unable to add an update site or my site. I get an error "could not log in (incorrect password?) although I have changed my password on the change update password page.

Any thoughts?

Thanks


#25

Hello,

I attempted to change the password and now I am getting this instead:
“action: changeuploadpassword
Error setting upload password for user ‘M_farna’: Permission denied”

Any thoughts?

Thanks


#26

@aneevel Please investigate.


#27

While people are waiting for news: did you test with a password that does not have symbols? My current theory is that the failure depends on which characters are present in the password.


#28

Hi all,

I’ve done some testing and made changes to problematic characters that I noticed; I hope my fix caught them all. If you could test out your individual errors again, I can see if it did so.


#29

I just replaced the $ sign in my password and now it works nicely.

Wouldn’t it make sense to publish a list of allowed/denied special characters on the page where you can update the password?

Thanks for your support @aneevel !

Cheers,
Robert


#30

Great suggestion @haesleinhuepf!


#31

What would make sense is to fix the script so that these characters work as expected. Or else reject the password outright instead of purporting to change it. In short: this is a bug, and we should fix it.


Exception error message when running "Read And Write Excel" plugin
#32

Hello,

I removed all special characters (now its letters only) from my password and now I am getting a different error: “did not get a token!”.

Any thoughts?

Thanks,
Mai


#33

@m_farna That is a new one on me. I was again able to change my own upload password successfully yesterday evening. Can you please paste the entire output from the web browser?


#34

I am having this problem again, made a new Wiki account and try to link an update cite, please find attached the screenshot with the error I get.

The password is correct. Could it be that I am trying to use the same email id for a new wiki account?


#35

Instead of using the “Add my site” button, which is not well tested in recent years, please visit the following page to initialize your update site: https://imagej.net/Special:ChangeUploadPassword