Unable to add site in updater

imagej
updater

#1

Hello,
I am trying to upload a plugin developed in our lab and every time I enter username and password I get an error message on Fiji console:

Error setting upload password for user ‘M_farna’: Permission denied.

Any help would be much appreciated.

Thanks,
M_Farna


#2

Welcome to the forum, @m_farna!

Please visit the following page:

http://imagej.net/Special:ChangeUploadPassword

You should be able to set your upload password there, then use it from the ImageJ updater interface.

Let us know if this does not work!


#3

Hello,

the problem seems to be solved for you M_Farna, but it persists for me. When trying to change the upload password via http://imagej.net/Special:ChangeUploadPassword it only responds “bash: Falk: command not found - Failed!”. It seems to somehow interpret my username as shell command. Very weird.

Any ideas?

Thanks in advance and all the best,
Thorsten


#4

Hi,
just want to add “me to” :frowning:

Same problems with upload password for ‘Schier’: updater denies to upload, and I can’t change the password from my page.

Thanks,

Jan


#5

Same issue here…

Any advice @ctrueden?


#6

I do not have time to investigate now, but @aneevel will do so.


#7

Hello all,

I’ve made some changes to the associated ChangeUploadPassword and verified that I am able to change my own password. If you are still unable to do so yourself, please inform me!

Thanks,
Alec


#8

@aneevel

I was able to change my password. However, I cannot add a new update site. I’ve followed the instructions in the mail and got the following error:

http://sites.imagej.net/TraJClassifier/ does not exist yet!

If I try to use “Add my site” then I got this error message

action: changeuploadpassword
Error setting upload password for user 'TraJClassifier': Permission denied

#9

@aneevel

Similar here: Also able to set the password, but the updater does not allow me to upload the .jar file with ‘sites.imagej.net asks for authorization’ message.

Many thanks for your help!


#10

Same for me.

The PasswordChange site now claims that the password change worked and I got notified by mail about the change. However, when I try to upload a revised jar file, neither old nor new password are accepted. The updater tells: “sites.imagej.net asks for authentication. Falk’s personal update site”. No further error messages are shown for me.


#11

Everyone affected by this issue: could you please test again? We have made changes which we believe address the issue.

However, it is possible there is more than one distinct issue here. It would be helpful to hear back from anyone who is still having problems with the ChangeUploadPassword page.

Thanks!


#13

The changed password still doesn’t seem to work for authentication during an upload.


#14

It does not work but my error message changed:

[ERROR] http://sites.imagej.net/TraJClassifier/ does not exist yet!


#15

Just tested it, but I experience the same behavior. When trying to upload the password dialog appears, after entering the password, a new dialog asking for username and password pops up, which can be repeated forever. I also tried to change the password again via http://imagej.net/Special:ChangeUploadPassword, no difference


#16

The same, no change in behavior, which is the same as @falk reports: I can change the password on the “Initialization or Change” page, but when trying to upload, I get stuch in the username/password dialog.


#17

Hi all,

I apologize for asking again, but could you please test your individual issues again? I hope this solution is able to resolve all your lingering issues!

Thanks!


#18

It worked this time. I did have to change the password again after your change (expected, but in case others don’t realize), and I am now able to upload.

Thank you!


#19

I had to change my password again but it works now.


#20

It works. Thank you very much!


#21

I also encountered this problem today, when attempting to upload to the Java-8 update site. After a couple of cycles changing my password and then failing to upload successfully, it occurred to me to try a password without symbols. When I did that, I was able to upload.

So @aneevel, my guess is that there is a bug in the script when the submitted password contains symbols, probably relating to encoding of certain characters. Or more specifically, failing to decode them before calling the password changing routine.