Ui-behavior not distinguishing "pressed" & "released"?



Hi sci-java gurus,

Somewhere between ui-behavior-1.3.0 and 1.6.0, the code below broke.

Specifically, those actions that refer to “released” actions end up replacing the “pressed” actions that were added to the map first, with the result that the earlier actions will never be triggered.

Is this a bug? Or is there a new way to specify press vs release in ui-behavior?

Many thanks!

How to align images manually and merge them into a multi-channel composite image?


Hi John,

Was there a solution to this problem? I am having the same error previously reported (https://github.com/saalfeldlab/bigwarp/issues/44), where “landmark mode” doesn’t work. Was working fine and then, opening up a new set of images for alignment, pressing space bar no longer did anything. Tried using older versions of ImageJ and didn’t solve the problem.



Hey @Sam_Weiser_Novak,

Temporary fix here:

Sorry you ran into this, I’ve just been swamped all month. Finally coming up for air now. Better fix coming!


p.s. thanks for resurrecting this thread, btw.
@tpietzsch, have you run into the above?


Hmmm, no…

Actually, I never used pressed or released modifiers in specifying keys. So no wonder that this got broken.
I can have a look at wether it is easy to restore at some point.

There should be an easy workaround though:
You could define a DragBehaviour (and ignore the mouse-coordinates).
Bind it to "SPACE | shift alt ctrl". (The | shift alt ctrl part says: ignore those keys.)
Then you should receive DragBehaviour.init(x,y) when SPACE is pressed, and DragBehaviour.end(x,y) when SPACE is released again.



Thanks John! Installing the latest un-released version fixed the issue.



Hi John,

I had the same issue with the Landmark mode not working and replaced the bigwarp_fiji.jar by the latest un-released version. Now when I press the space bar, bigwarp does switch to landmark mode. However when I hold the space bar, it keeps switching rapidly (several times per second) between landmark mode and viewing mode, making almost impossible to place landmarks accurately. I am running version 1.52e on a windows 10 machine. Any idea how to fix this?

Many thanks,




The mode of operation for bigwarp hast changed due to this bug. Instead of activating the landmark mode only while the space bar is down, the landmark mode is now toggled with the space bar, i.e. just press and release the space bar and you will be able to set your landmarks.


Ah, I missed that. It does works like that. Thank you for your help.