Ubuntu 16.04 LTS installation problem setup.py

cellprofiler

#1

Hi,

I am trying to install CellProfiler on Ubuntu 16.04 LTS.

Once I run: ‘pip install --user --editable .’ I get the following error:

Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/home/local/pfistere/CellProfiler/setup.py”, line 279
for ext in “.ui”, “.png”])]

SyntaxError: invalid syntax

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /home/local/pfistere/CellProfiler/

I hope somebody can help me with this…

Thank you very much,


#2

Hi, @chol! From your stack trace:

Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in 
File “/home/local/pfistere/CellProfiler/setup.py”, line 279
for ext in “.ui”, “.png”])]

it looks like you’re using a very old version of CellProfiler. How did you download the source repository?


#3

Hi,

thanks for your reply. I followed the instructions on the source installation site.

git clone https://github.com/CellProfiler/CellProfiler.git cd CellProfiler

git checkout stable

I got the error with both checkout stable and also when I tried checkout 2.2.0.


#4

@chol You need to checkout tags/3.0.0.


#5

This fixed it for me! I don’t know why the stable branch points to an old version, so this page should probably be updated.

I used tags/v3.0.0 and this made everything work super smoothly!