Trouble installing Napari

Hello -

I’m trying to install napari for the first time on my system and am running into some issues. I created a new environment … made sure to install Python3 (version 3.4.3)… and I am unable to run pip install napari. I keep seeing this error:

(napari-env) : ellenarena@Med-Dev-MacBook ~/code/napari/napari (master) »
pip install napari                                                                     #  0 {2020-05-31 14:06:14}
Collecting napari
  Could not find a version that satisfies the requirement napari (from versions: )
No matching distribution found for napari

I also tried cloning the repository locally as per the instructions here… but when I run pip install -e ., I get the following error:

(napari-env) : ellenarena@Med-Dev-MacBook ~/code/napari (master) »
pip install -e .                                                                       #  0 {2020-05-31 14:05:48}
Obtaining file:///Users/ellenarena/code/napari
  Installing build dependencies ... done
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/Users/ellenarena/code/napari/setup.py", line 17
        MIN_PY_VER = f"{MIN_PY_MAJOR_VER}.{MIN_PY_MINOR_VER}"
                                                            ^
    SyntaxError: invalid syntax
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /Users/ellenarena/code/napari/

As a result of this error - I ran pip install --upgrade setuptools … that seems to have gotten me past that code 1 error… but now I have a new one:

(napari-env) : ellenarena@Med-Dev-MacBook ~/code/napari/napari (master) »
pip install -e .                                                                       #  0 {2020-05-31 14:12:29}
Directory '.' is not installable. File 'setup.py' not found.

And now I’m at a loss… any thoughts on this?

Many thanks!

there’s the problem. We only support python >= 3.6

1 Like