TrakEM2 not working on Mac

I am using TrakEM2 to make a 3d projection of my image. After I have drawn all of my areas and try to show in 3D not all of my area lists are reconstructed and I get the error “reset 3D view if not in field of view.” I am running OSX El Capitan with the latest Fiji updates and java 8. I tried downloading Fiji lifeline version from Dec 22, 2015 but it wouldn’t open. I also tried resetting the java version to 6 instead of 8, but got an “operation not permitted” message. Any thought?

Hi @dinger,

Welcome to the forum!

I get the same behaviour when I try this - looks like you found a bug.

What works for me is to open Fiji’s 3d viewer while I have trakem2 open. Specifically, while trakem2 is open,I do:

  • Plugins > 3D Viewer in Fiji’s menu.
  • Then it opens the 3d viewer with my area lists and image data.

Does that work for you? Will it be an acceptable work-around?

John

1 Like

When I do that only my actual image stack but not my area lists are displayed in the 3d viewer.

2 Likes

Hi,

I’m also having this issue but on Windows 10 (10.1.2.80). Is there anyway to fix the bug?

Regards,

Mohammed