Training in Colab after Labeling in Windows7 or Ubuntu 14.14/18.04

After labeling in Windows 7 or in Ubuntu 14.04/18.04 I get the following Error when I try to use the function “deeplabcut.create_training_dataset” in Colab.

ModuleNotFoundError Traceback (most recent call last)
in ()
----> 1 deeplabcut.create_training_dataset(path_config_file)

2 frames
/usr/local/lib/python3.6/dist-packages/pandas/core/generic.py in to_csv(self, path_or_buf, sep, na_rep, float_format, columns, header, index, index_label, mode, encoding, compression, quoting, quotechar, line_terminator, chunksize, tupleize_cols, date_format, doublequote, escapechar, decimal)
3005
3006 # if all axes that are requested to reindex are equal, then only copy
-> 3007 # if indicated must have index names equal here as well as values
3008 if all([self._get_axis(axis).identical(ax)
3009 for axis, ax in axes.items() if ax is not None]):

ModuleNotFoundError: No module named ‘pandas.io.formats.csvs’

I’m trying to use Colab because all my computer have super old gpu’s. I haven’t found any issues if I train the model using the conda-environments in windows 7 or Ubuntu 14.04/18.04.

Any ideas how to solve it? Thanks!

can you link to the notebook you are using? I cannot reproduce your error with the current version here:
https://colab.research.google.com/github/AlexEMG/DeepLabCut/blob/master/examples/Colab_TrainNetwork_VideoAnalysis.ipynb#scrollTo=eMeUwgxPoEJP

And, note where it says you must click reset runtime, do this, so you are sure to have pandas 0.21.0:
image

If you don’t, then you will get that error you describe!

Issue Solved, Thanks!

1 Like