Trainable weka segmentation java error

Hi All,
As I tried to start trainable weka segmentation plugin, I get the following java error. Please
help. Thanks.

1 Like

Hello @hello_fiji,

It seems you need to update your java. Please go to the ImageJ updater (Help > Update) and select the Java-8 update site after clicking on Manage update sites. After closing that window, you should be prompt to download the java update and restart Fiji.

ignacio

3 Likes

Thank you very much. It works now. :slight_smile:

3 Likes

For anyone who finds this thread later: note that turning on the Java-8 update site does not actually update any Java installations. It updates to the latest ImageJ and Fiji components, many of which require Java 8 to function.

It also updates the ImageJ Launcher component to seek out installations of Java 8+ only, which means the old Java 6 previously bundled with Fiji will no longer be used. So that might explain why doing this procedure worked in @hello_fiji’s case. But if you don’t already have Java 8 installed on your system, turning on the Java-8 site might make your installation non-functional until you install Java 8.

Alternately, you can simply download a fresh copy of Fiji which is now bundled with Java 8, and has the Java-8 update site enabled.

1 Like