Trainable Weka Segmentation Broken by shutdown

a power surge shut down my Win10 computer during a long Trainable Weka Segmentation run and FIJI TWS is not working correctly since.

I get this

(Fiji Is Just) ImageJ 2.1.0/1.53e18; Java 1.8.0_172 [64-bit]; Windows 10 10.0; 118MB of 9130MB (1%)
 
java.lang.NoClassDefFoundError: Could not initialize class trainableSegmentation.Weka_Segmentation
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.lang.Class.newInstance(Class.java:442)
	at ij.IJ.runUserPlugIn(IJ.java:238)
	at ij.IJ.runPlugIn(IJ.java:203)
	at ij.Executer.runCommand(Executer.java:150)
	at ij.Executer.run(Executer.java:68)
	at java.lang.Thread.run(Thread.java:748)

I updating Java runtime on the machine, and dropping back to an older saved version of my FIJI folder, but I still get the error. Ridge Detection still works fine as do the buttons and stuff in the image dropdown like scale and crop. I’m stumped! Any help would be appreciated.

Thanks
Ron DeSpain

@rondespain

Have you just tried a new, fresh download/install of Fiji? Does the problem then persist??

I tried a fresh download this morning and it did fix the problem. I guess I’ll have to just move the plugins, jars, etc folders from the old install to the new and see if the problem reappears. Thanks for your response.

Ron

I’m still getting these errors intermittently.vut in the same order. Sometimes it runs after the errors and sometimes not. Any ideas what is missing from my install. I’m using FIJI and I’ve run an update at imaging science, but still these weird errors.

tws error1

tws error 2

Have you tried replacing them? If something managed to corrupt your installation, you may have other issues as well.