TrackObjects module not working?

cellprofiler

#1

Hi All,

I am trying to track cells for a cell motility assay, and I can’t get TrackObjects module to work.

Running CellProfiler 1.0.7522 on windows XP, and same version on Suse Linux.

I have tried in many ways, including with idenfityPrimAutomatic, but currently the pipeline looks like:

  1. LoadImages - importing a single greyscale AVI video that has 48 frames. No problem with the format, can do other processing on it no problem.
  2. TrackObjects - default settings.

It makes it through one cycle, and then gives this error:

There was a problem running the image analysis. Sorry, it is unclear what the problem is. It would be wise to close the entire CellProfiler program in case something strange has happened to the settings. The output file may be unreliable as well. Matlab says the error is: Reference to non-existent field ‘Nuclei’. in the TrackObjects module, which is module #02 in the pipeline.

Stack:
TrackObjects in C:\Documents and Settings\jsexton\Desktop\CompiledCellProfiler_7522\CellProfiler_mcr\Modules\TrackObjects.m (248)
AnalyzeImagesButton_Callback in C:\Documents and Settings\jsexton\Desktop\CompiledCellProfiler_7522\CellProfiler_mcr\CellProfiler\CellProfiler.m (10890)
gui_mainfcn in C:\Documents and Settings\jsexton\Desktop\CompiledCellProfiler_7522\CellProfiler_mcr\CellProfiler\CellProfiler.m (12633)
CellProfiler in C:\Documents and Settings\jsexton\Desktop\CompiledCellProfiler_7522\CellProfiler_mcr\CellProfiler\CellProfiler.m (57)

Is this a bug? Are there any workarounds for tracking in this software?

Thanks! - Jonny


#2

Hi Jonny,

Unless I’m mistaken, is it the case that your pipeline has only these two modules in it?

If that’s the true, the reason it won’t work is that the module is looking for a Nuclei object and can’t find one because it hasn’t been created. TrackObjects requires previously identified objects as input, such as those detected by IdentifyPrimAutomatic or IdentifySecondary.

Regards,
-Mark


#3

Have you tried loading the example TrackObjects pipeline found here http://www.cellprofiler.org/examples.htm ?
It outlines what Mark already said, and more.

Best,
Dave


#4

OK, great got it working…

I read some other post about TrackObjects that seemed to indicate that object identification wasn’t necessary.

I tested with my video and I realized that the minimum object size was too small, so the algorithm didn’t actually identify any objects. This is why TrackObjects was complaining.

Problem solved, thanks for the help!

Jonny


#5

Could you tell us which post that was? If that’s the case, I’ll correct it; we certainly wouldn’t want to lead anyone down the wrong path!
-Mark