TrackMate crashes when calculating the cost matrix

Hi,

For a short time TrackMate crashes during calculation of the cost matrix, which is strange, since I am using a test-data-set, which worked fine before!

Here is the error message; maybe someone has a suggestion/hint?

Exception in thread "TrackMate tracking thread" java.lang.NoSuchMethodError: org.jgrapht.Graph.getType()Lorg/jgrapht/GraphType;
	at org.jgrapht.alg.connectivity.ConnectivityInspector.<init>(ConnectivityInspector.java:69)
	at fiji.plugin.trackmate.tracking.sparselap.costmatrix.GraphSegmentSplitter.<init>(GraphSegmentSplitter.java:24)
	at fiji.plugin.trackmate.tracking.sparselap.costmatrix.JaqamanSegmentCostMatrixCreator.process(JaqamanSegmentCostMatrixCreator.java:160)
	at fiji.plugin.trackmate.tracking.sparselap.linker.JaqamanLinker.process(JaqamanLinker.java:102)
	at fiji.plugin.trackmate.tracking.sparselap.SparseLAPSegmentTracker.process(SparseLAPSegmentTracker.java:131)
	at fiji.plugin.trackmate.tracking.sparselap.SparseLAPTracker.process(SparseLAPTracker.java:179)
	at fiji.plugin.trackmate.TrackMate.execTracking(TrackMate.java:262)
	at fiji.plugin.trackmate.gui.descriptors.TrackingDescriptor$1.run(TrackingDescriptor.java:55)

the log:

Geometry:
X = 0 - 131, dx = 0,104000
Y = 0 - 123, dy = 0,104000
Z = 0 - 0, dz = 1,00000
T = 0 - 99, dt = 0,0290000
Spot feature analyzers:

  • Cell division time on spots provides: Cell div. time.
  • Manual spot color analyzer provides: Spot color; is manual.
  • Spot descriptive statistics provides: Mean, Median, Min, Max, Total int., Stdev.
  • Spot radius estimator provides: Diam.
  • Spot contrast and SNR provides: Constrast, SNR.
    Edge feature analyzers:
  • Edge target provides: Source ID, Target ID, Cost.
  • Edge mean location provides: T, X, Y, Z.
  • Edge velocity provides: V, D.
  • Manual edge color analyzer provides: Edge color; is manual.
    Track feature analyzers:
  • Cell division rate analyzer provides: Mean div. time, Std div. time.
  • Branching analyzer provides: N spots, Gaps, Longest gap, Splits, Merges, Complex.
  • Track duration provides: Duration, T start, T stop, Displacement.
  • Track index provides: Index, ID.
  • Track location provides: X, Y, Z.
  • Velocity provides: Mean V, Max V, Min V, Median V, V std.
  • TRACK_SPOT_QUALITY provides: Mean Q, Max Q, Min Q, Median Q, Q std.
    Computing spot features.
    Computation done in 47 ms.
    Computing edge features:
  • Edge target in 0 ms.
  • Edge mean location in 0 ms.
  • Edge velocity in 0 ms.
    Computation done in 0 ms.
    Computing track features:
  • Cell division rate analyzer in 0 ms.
  • Branching analyzer in 0 ms.
  • Track duration in 0 ms.
  • Track index in 0 ms.
  • Track location in 0 ms.
  • Velocity in 0 ms.
  • TRACK_SPOT_QUALITY in 0 ms.
    Computation done in 0 ms.
    Starting detection using LoG detector
    with settings:
  • target channel: 1
  • threshold: 0.0
  • do median filtering: false
  • radius: 0.5
  • do subpixel localization: true
    Starting detection process using 4 threads.
    Detection processes 4 frames simultaneously and allocates 1 thread per frame.
    Found 12368 spots.
    Detection done in 0,6 s.
    Computing spot quality histogram…
    Histogram calculated in 0,2 s.
    Initial thresholding with a quality threshold above 18,8 …
    Starting initial filtering process.
    Retained 10 spots out of 12368.
    Calculating spot features…
    Computing spot features.
    Computation done in 47 ms.
    Calculating features done in 0,0 s.
    Performing spot filtering on the following features:
  • on Quality above 26,0
    Kept 2 spots out of 10.
    Starting tracking using Simple LAP tracker
    with settings:
    Linking conditions:
    • max distance: 2,0
    • no feature penalties
      Gap-closing conditions:
    • max distance: 2,0
    • max frame gap: 2
    • no feature penalties
      Track splitting not allowed.
      Track merging not allowed.
      Starting tracking process.

That’s strange. Do you maybe have a third-party update site activated that brings in an older version of jgrapht? In an up-to-date Fiji, you should have jars/jgrapht-1.3.0.jar. The last version that didn’t have the Graph#getType() method seems to be 1.0.0.

3 Likes

thank you for your response! sorry for the late reply!

As you suggested, I installed a few plugins recently (after that TrackMate crashed). I will reinstall Fiji and report back to you, whether TrackMate is working again.

1 Like

after reinstalling Fiji, its working again :)! The update sites I am using currently are: Bio-formats, ilastik, Mosaic-ToolSuit, ImageJ-Matlab; I skipped a few others, which I do not need currently. When I’ll figure out, which Plugin might be the cause, I will post it here.

I got the the same error when using TrackMate and when looking at the update sites it seems Filament Detector was requiring an incompatible version of jgrapht. After uninstalling it, TrackMate works again.

1 Like