Tile request exception - WSI higher resolution layer not loading

Hello,

I have an issue with .ndpi WSI coming from a particular slide scanner (Hamamatsu S60) not loading the high resolution image layers in QuPath. It seems like only the overview macro image is loaded but not 4x and higher.

This problem occurs only in QuPath M8 and according to my colleague, some older versions as well. These WSI could be opened in at least two other WSI viewers (Aperio ImageScope and NDP.view2) and viewed just fine.

I tried opening using OpenSlide and Bioformats in QuPath M8, but neither works. OpenSlide could open the macro image and Bioformats could not even load that properly.

In the log, WARN: Tile request exception pops up whenever I try to zoom in.

Any ideas what may be causing the problem?

The slides I have are clinical samples for now so I’d rather not upload it, but I will be scanning some mouse sections and can upload them soon if you need those for troubleshooting.

Many thanks,
Yau

Hi,
This is a known shortcoming in QuPath right now! It will probably be resolved in the next versions :slight_smile:

The -temporary- solution is to open your slide in a project, rather than just in QuPath at start-up.
QuPath will then load both the macro and the higher resolution image (or more if you file contains more slides).

Good luck!
Melvin

Hi Melvin!

I did open the WSI in a project and the problem is still there :frowning:

The other .ndpi I got from another Hamamatsu S360 (not S60) works completely fine. I’m using the S60 at the moment because the S360 is undergoing repairs.

Does the file open when you use the BioFormats importer in FIJI?

The last time an issue with an S60 came up, it was a file name length issue:

When opening the WSI using BioFormats importer in FIJI, the thumbnails look weird for the high resolution layers (label intentionally blurred):
image

And when loaded:

I renamed and moved the WSI to C:\Users\myuser\test\test.ndpi and the same error still happens.

You may want to submit a test sample to BioFormats then once you have one you can share, as @joshmoore requested in the previous thread. If Openslide doesn’t work, and BioFormats is giving this kind of problem in FIJI, it likely would have to be solved on the BioFormats side.

Could you share the log to get a more precise idea of what might go wrong please?

1 Like

I’ve attached the log from the moment I open the WSI and start zooming in.
log.txt (3.2 KB)

I don’t think it’s very informative though…

I have a some more info that may be relevant:

<class 'openslide.lowlevel.OpenSlideError'> An error produced by the OpenSlide library.      
Import this from openslide rather than from openslide.lowlevel.      
'Corrupt JPEG data: found marker 0xd9 instead of RST0'

This error message appeared when I am trying to open the problematic slide using OpenSlide for another purpose (testing HistoQC).

Do these ‘markers’ mean anything to you? @melvingelbard @petebankhead @joshmoore

I’ve managed to solve the problem.

It’s an issue with the jpeg subsampling ratio during .ndpi output from the Hamamatsu NanoZoomer S60 scanner.

Jpeg subsampling ratio of 4:1:1 was causing the issue and when I used 4:2:2 or no subsampling, the problem did not occur.

Strangely, the other Hamamatsu NanoZoomer S360 that we have is using 4:1:1 without problems… A mystery to solve another day.

3 Likes