SWC extension tracing issue


I have encountered an issue with the Simple Neurite Tracer when I load a SWC file. When I reach a certain number of paths, a number of lines appear when I open the file after closing the program. These lines do not appear for all the paths, though, and they become green when I select the associated path. Example in the image:

Does anyone why it happens and how to solve it?

Thanks in advance!

Perhaps @tferr can assist you in this?

I have never seen this before. It looks as if the swc file is ill-formed: The flag indicating the parent branch for the erratic paths was missing, and the program assigns them to the origin (x=0,y=0) of the tracing canvas, i.e., the upper left corner of the image.
It would be really useful to know how you obtained this swc file: From SNT directly, another program? Can you place the original image, the SNT .traces file you may have and the problematic SWC file somewhere we can access them?


Just a quick followup. Did you manage to solve the issue?

Hi, tferr!

Yes, it has been solved.

I obtained the file using SNT. I showed the issue to my supervisor and he has solved it somehow, fortunately. As you have said, it sets the coordinates to origin, for some reason.

I will ask him if he minds if I share the original image.

Thanks a lot!

Hi tferr.
Similar issue here, as I noted in another thread. The head of a new path often gets put at (0,0,0), instead of the coordinate of the parent node. It happens when I’m importing an swc that had been exported by SNT. The traces file is fine.

This issue of “ghost” nodes with zero coordinates upon editing of paths should now be fixed with SNT-3.1.113 released today. This issue has also been reported in another post.