Suppress warning during batch processing of bonej2 Anisotropy

Hello everyone,

I would like to process a set of 3D images using the anisotropy tool in bonej2. I would like to use the batch processing mode in Fiji for that. I made a macro to run the anisotropy tool and pasted it in the batch processing tool to process all images in a given folder. This works, but everytime the anistropy tool is started, a warning pops up saying: “NB parameter values can affect results significantly”.

I have to click “OK” before the tool can be started, which means that I cannot really run the batch mode without physically pressing this button everytime the anisotropy tool is called. Is there a way to suppress this warning?

Thank you in advance!
Sebastien

Hi @Sebastien_Callens,

This is known issue. You can get around it by adding a instruction=\"\" parameter to your macro.

Best,
Richard

2 Likes

Hi @rimadoma,

Thanks for this super fast reply! It works indeed by adding this to the macro :+1:t4:

Best,
Sebastien

1 Like