Suppress Importer output to Fiji Console

I’m running a macro in batch mode which processes a large number of Gatan DM4 files. Every time a file is opened, the following message is output to the Console window:

Verifying Gatan format
Reading tags
Populating metadata
[WARN] Unknown Correction value ‘Unknown’ will be stored as “Other”
[WARN] Unknown Immersion value ‘Unknown’ will be stored as “Other”

Other than being inconvenient, this also slows down the processing. Is there any way to suppress this output ?

You can set Quiet mode on the ImporterOptions, for a macro it will likely look something similar to the below example. Simply include quiet in the list of import options:

IJ.run("Bio-Formats Importer", "open=[" + initiatorFilePath + "] color_mode=Grayscale concatenate_series open_all_series quiet rois_import=[ROI manager] view=Hyperstack stack_order=XYCZT")

Hi. Unfortunately that does not work. Exactly the same message is displayed.
I have attached a DM4 file in case anyone wants to test. Other ideas are welcome :slight_smile:

test.zip (285.3 KB)

My apologies @ovcretzu, I thought that should have resolved it. I have opened a Bio-Formats Trello card to further investigate why the logging level isn’t changing: https://trello.com/c/Jd980O9M/385-imagej-logging-levels