Stretching Img in Plate Viewer

Hi,

I’m starting to use the Plate Viewer feature, but I have not found any way to stretch the image intensities. Without this feature the feature is useless to me, since in screening we minimise the acquisition time and do not fully use the dynamic range of the cameras. I essentially get a dark image. I didn’t find any post about this and nothing in the help either. Any suggestions?
Thanks,
Marc

Hi Marc,
Are you trying to use CellProfiler’s or CellProfiler Analyst’s Plate Viewer? Just want to make sure I’m helping you with the right issue.

Hi Beth,
Thanks for looking into this. I’m using CellProfiler itself, not the Analyst. The idea is before the analysis to be able to look at the cells.
Bye,
Marc

Marc Bickle, PhD
Head HT-Technology Development Studio
Max Planck Institute of Molecular Cell Biology and Genetics
Pfotenhauerstr. 108
D-01307 Dresden
Germany

phone +49 351 210 2595
fax +49 351 210 1689
mail bickle@mpi-cbg.de mailto:bickle@mpi-cbg.de
web: http://www.mpi-cbg.de/facilities/profiles/ht-tds.html http://www.mpi-cbg.de/facilities/profiles/ht-tds.html

DRESDEN-concept Technology Platform:
https://tp.dresden-concept.de https://tp.dresden-concept.de/

Great, that gives me a place to start. I don’t have a good data set right in front of me to start tinkering, but can try that tomorrow or Friday; in the meantime, can you check if updating your default display settings (under File->Preferences) to ‘log normalized’ then reopening PlateViewer gives you a stretched view or if it’s still black? I’d think/hope that PlateViewer respects the current defaults, but if it doesn’t I’ll have to try to think of something clever or file a bug report to change its behavior such that it does.

Hi,

I don’t see that in the Preferences, but I use 2.1 since 2.2 does not work on any computer of my laboratory. I never made a report because simply too many things don’t work.
I’m working on a Mac and the Preferences are under CellProfiler-> Preferences. I don’t see any Preferences under File, but this might be a Mac/PC thingy.

Thanks,
Marc

Marc Bickle, PhD
Head HT-Technology Development Studio
Max Planck Institute of Molecular Cell Biology and Genetics
Pfotenhauerstr. 108
D-01307 Dresden
Germany

phone +49 351 210 2595
fax +49 351 210 1689
mail bickle@mpi-cbg.de
web: http://www.mpi-cbg.de/facilities/profiles/ht-tds.html

DRESDEN-concept Technology Platform:
https://tp.dresden-concept.de

Hmm, yes, I think that option was added in 2.2. You’re right that on Mac CellProfiler->Preferences would be the place to check. I’ll try to poke around in 2.1 later this week but my guess is that it may not be possible to do the rescaling in that older version.

I’m sorry to hear that you’re having trouble getting 2.2 installed- on Macs, you need to make sure you have a newish 64 bit Java and the Java Development Kit installed- links to both are on the “releases” page. There are a lot of new features that may make it worth the time to get it installed; please let me know if I can help you with that.

Hi,

well just today I reinstalled together with the latest release of Java and still no cigars. Sure, we can discuss what the problem might be, but I should open a new topic?
Marc

Marc Bickle, PhD
Head HT-Technology Development Studio
Max Planck Institute of Molecular Cell Biology and Genetics
Pfotenhauerstr. 108
D-01307 Dresden
Germany

phone +49 351 210 2595
fax +49 351 210 1689
mail bickle@mpi-cbg.de
web: http://www.mpi-cbg.de/facilities/profiles/ht-tds.html

DRESDEN-concept Technology Platform:
https://tp.dresden-concept.de

That’d be perfect, thanks. Please make sure to post your OS version and any error messages you may be receiving. Thanks again!

Hi Marc,
I apologize for the delay in getting back to you- I had reduced time and brainpower as I was at a conference last week and once I started working on your other issue this got stuck in a crack.

The place to change the scaling values in both 2.1 and 2.2 for your images is the red arrow below. Below is an image from an open-source dataset where, like you, they’re not using the full dynamic range. When you open PlateViewer with the default values you get this:

After updating the multipliers, I get this:

We definitely could do a much better job documenting what all of the various parts do, and I’m updating the help in the code now- it should go live in our next release. Thanks for your help pointing out this issue, and I apologize for your inconvenience!

Hi Beth,

this is very cool. I did try changing those values, but never tried going above 255: DUH! Well that solves this neatly. I’ll communicate this to the guy at AZ.
I have to apologize too, because I had no time to retest 2.2 and check the permissions. I have several hours of train ride during the weekend and plan to do just these kind of things and also write some code.

Thanks again,
Marc

Marc Bickle, PhD
Head HT-Technology Development Studio
Max Planck Institute of Molecular Cell Biology and Genetics
Pfotenhauerstr. 108
D-01307 Dresden
Germany

phone +49 351 210 2595
fax +49 351 210 1689
mail bickle@mpi-cbg.de
web: http://www.mpi-cbg.de/facilities/profiles/ht-tds.html

DRESDEN-concept Technology Platform:
https://tp.dresden-concept.de

2 Likes