Spot intensity analysis

Spot intensity analysis problem?
I was trying to analyse the dot blot spot intensity but each time I run the analysis , the console comes up with an error message given below,

Exception in thread "Thread-5" java.lang.IllegalArgumentException: Argument out of range
	at ij.ImageStack.crop(

I am a person who doesn’t know programming and have no idea what has to be done to rectify the issue. Kindly help me sort it out at the earliest.
Thank you


Welcome to the Forum!

Can you provide a bit more information? What exactly are the steps you are using to carry out your analysis? Can you post an original image/dataset so we can take a look at your data?

For Dot Blot analysis - this page is might be of help to you if you haven’t seen it before.

Once we have the above info - it will be easier to get you some help.

eta :slight_smile:

1 Like

Hello @etadobson ,

I have uploaded an image of the dot blot.
The steps used was initially I open the image, click on plugins, in plugins click analyse, in analyse use the spot intensity analysis of Fiji.
I am using this for the first time so like any amateur I just gave a try by doing the above steps. But each time I tried the console showed an error message, since I am not into programming I was unable to sort it out.
I had looked into the Dot blot analysis page you have suggested, bu I was not getting the values of the peak.

Thank you for replying


Regarding Spot Intensity Analysis … perhaps @nicost can provide some assistance and insight - as I have not used this tool myself. For example - at what exact step in the analysis does the error occur?

And can you try once again to upload an original image that you are using? It was not attached in the previous post.


The purpose of the Spot Intensity Analysis is to plot the intensity of fluorescent spots over time (see: It is the wrong tool for dot blot analysis. I am pretty sure that ImageJ has tools for that purpose, especially since one of the original example images is a dot blot.


Hi Eta and Nicost,

As Nicost said I was using the wrong tool, I have tried to sort it out using the Gel analysis tool for the dot blot image I was having. I was trying to work with the dot blot example of ImageJ, but I had trouble using the example because the image of the dot blot for the example was not opening in ImageJ. It was showing error and no network connection, timed out and so. But I was working continuously with other things on the network, I have no idea why it was showing error timed out. I am still trying to get the image (example) for sorting if I am using the tool correctly, but have failed to get the example image from Imagej. I tried to get images of other tools to see whether it was problem with only dot blot but it was problem with all, none of the images (examples) open in the imagej. Probably will try to uninstall the Fiji and reinstall again.
Lets hope the problem gets solved with the reinstallation.

Thank you Eta and Nicost

That is your best bet @Vrinda … just let us know if you need any more help with anything.


Are you looking for actual values for the data? Or just a visual indication?
If a visual indication is all that is needed then you can use a LUT of preference.
If you need the actual values you can send the image LUT in ; Export as Text in the File menu.
Hope this helps