Split and ColorToGray not recognizing 4th channel in .TIF

I have added a 4th channel to a previously functional pipeline (thanks for the great software!) and now when the image is splitting the channels in the ColorToGray function I get the following error:

A screenshot of my ColorToGrayPipeline is at the bottom

My concern is that the only difference between what was working and what I am not trying to do is the addition of this 4th channel. I generate the fourth channel using the same merge function that I used to create the 3-channel merge that worked fine. Is “Alpha4” not the correct channel number? I get the same error when I substitute for any of the unused channel numbers.

After reading through some of the other posts I checked that my images are all the same size and I attempted to use the .zvi file and metadata to generate my four channels without luck.

I am also uploading the pipeline as well as the merged .TIFF file that I am trying to use and the .zvi file in the event that going the route of the .zvi and metadata are the better route and I simply couldn’t make it work.

Thank you for your help!

image.zvi.zip (6.1 MB)

quad pipleine attempt.cpproj (91.2 KB)

image_(DAPI GFP Texasred Cy5).TIF.zip (2.0 MB)

There was a known bug in an earlier build of 2.1; I thought it was fixed in 2.1.1 but may not have been. If you try downloading a newer build (2.2.0 or greater) does that fix your issue?

Thanks for the suggestion. Checking for updates through CellProfiler returns “Your version of cell profiler is up to date” even though the version is clearly 2.1.1. When I directly download and attempt to install v2.2.0 I get the error message: “CellProfiler Error”. Is it necessary to uninstall the previous version prior to installing the new version? I’m hesitant given the errors being thrown with this install.

It definitely is not necessary, assuming you’ve installed 2.2 into a different directory- I often have 3 or 4 builds installed at any given time. Is there any other text at all besides “CellProfiler Error”? That’d be helpful for diagnosis.

The only text is what is included in the Error message that I uploaded a screenshot of. Is there some way I can provide more information than that?

I’m sorry, I wasn’t clear, my bad. I was referring to this error:

When I directly download and attempt to install v2.2.0 I get the error message: “CellProfiler Error”.

Were you able to get CP 2.2 installed, and if not is there more information in the installation error? If you were able to install it, did it fix the issue?

When that error appears I have the option to “open console” or “terminate”. If I click “open console” the text in the attached file is displayed.

Thanks for your help

cell profiler error message.txt (5.1 KB)

It looks like there’s a Java error, make sure you have a recent Java Runtime Environment and Java Development Kit.

Thank you. That allowed me to download 2.2 and run the pipeline. In doing so, I got the same error message as before.

I downloaded your images and pipeline and found your problem; whatever merge function you were using to generate this .TIF didn’t generate a 4 channel TIF, it just squashed all 4 channels into an RGB tif, so when you tried to use ColorToGray in channels mode, it (understandably) failed to find 4 channels. The good news is that Metadata extraction from your ZVI seems to work and eliminates that middle step for you- see screenshots from Metadata and NamesAndTypes below to help get it configured correctly (ignore the labels it was assigning, I just let those auto populate).


1 Like