Speckle count issue

I am running a speckle assay (Neculei= DAPI; Speckle=Cy5). The assay plate was imaged 20X / deconvolution in GE2000. I applied a speckle protocol. However, there is no / or very few speckles in negative cotrols but it did show up plenty after running protocol. Could you please take a look at my protocol. It will be ideal if we can get > 30 speckles/cell in the positive control well and < 1 speckles/well in the negative control.
attached image file : A10 - positive control ; P7 -Negative control
by the way, does “Mean_Speckles_Parent_Nuclei” means “mean of speckle per cell” if I applied “parient object = nuclei” and “child object = speckle”? if the answer is yes, how come is not equal to calculation result of Count_Speckles / Count_Nuclei.
thanks
peii




peii count speckle for GE2000 images speckle size5.cp (7.84 KB)

(Moving post to appropriate board)

Hi Peii,

In the RelateObjects module in your pipeline, I notice that you have Speckles as both the parent and the child object. This is not the setting combination that you want; instead, use Speckles as the child and Nuclei as the parent.

“Speckles_Parent_Nuclei” is the label of the parent nuclei assigned to each speckle; it’s simply an identifier. Taking the mean of a label is basically meaningless, and should be ignored. I think the measurement you are looking for would be “Mean_Speckles_Children_Speckles_Count” which you would get if you check the “Calculate per-image mean values for object measurements?” box. You can also check the “Calculate per-image median values for object measurements?” box for good measure. (You also have the option of outputting the per-cell spreadsheets, so you can examine the per-cell speckles counts directly)

Once the above two adjustments are made, I get that Mean_Nuclei_Children_Speckles_Count is 4.67 for the “A” and 0.26 for the “B”, and 4 and 0 for each image under Median_Nuclei_Children_Speckles_Count which is quite a big difference. I think the reason that it is not >30 speckles per cell is that a large number of your cells will have fewer speckles, which will bring the mean/median down.

If you want to change the detection settings so that more speckles are detected in the A" case, I think you will need to either:

  • Leave the thresholding method as-is and adjust the threshold correction factor upwards to detect more speckles; or
  • Change the thresholding method plus the threshold correction factor as needed.

Keep in mind that adjusting things to detect more speckles in the positive case will probably detect more speckles in the negative case as well.

As a sidenote: your nuclei segmentation was not terribly good in the “P” images with the current settings. I would suggest changing the thresholding method to Otsu global with 3 class thresholding with the middle class set to Background.

Regards,
-Mark