Special characters no longer allowed in script parameter declaration

fiji
imagej
#1

Hello,

In the script parameter declaration ([https://imagej.net/Script_Parameters]), the label and description options may receive a text string :

#@Double(label = "Enter the length (µm)", description="Unit is µm", value = 1) length

This worked perfectly under Fiji 1.52b. However, after updating up to Fiji 1.52o, the special symbol µ is not displayed correctly. This is a possible bug introduced in the 1.52o version (Report Bug menu in Fiji is not available yet).

Thank you for reading.

#2

I cannot reproduce your issue on an up-to-date Fiji on Mac OSX.

An up-to-date Fiji ships an ImageJ 1.x version at 1.52n currently, and after updating the ImageJ 1.x component to the latest via Help > Update ImageJ…, you get 1.52o. In both cases, I got the µ character displayed correctly:

Could you please post the system details you get from Plugins > Debug > System Information?
Did you save your script as a file, or just used the script editor to run it?

2 Likes
#3

Plugins > Debug > System Information generates this error :

[Wed May 01 15:39:27 EDT 2019] [ERROR] [] Module threw exception
java.lang.NullPointerException
	at org.scijava.util.POM.compareTo(POM.java:190)
	at org.scijava.util.POM.compareTo(POM.java:54)
	at java.util.ComparableTimSort.binarySort(ComparableTimSort.java:262)
	at java.util.ComparableTimSort.sort(ComparableTimSort.java:207)
	at java.util.Arrays.sort(Arrays.java:1312)
	at java.util.Arrays.sort(Arrays.java:1506)
	at java.util.ArrayList.sort(ArrayList.java:1462)
	at java.util.Collections.sort(Collections.java:141)
	at org.scijava.plugins.commands.debug.SystemInformation.run(SystemInformation.java:154)
	at org.scijava.command.CommandModule.run(CommandModule.java:199)
	at org.scijava.module.ModuleRunner.run(ModuleRunner.java:168)
	at org.scijava.module.ModuleRunner.call(ModuleRunner.java:127)
	at org.scijava.module.ModuleRunner.call(ModuleRunner.java:66)
	at org.scijava.thread.DefaultThreadService$3.call(DefaultThreadService.java:238)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Did you save your script as a file, or just used the script editor to run it?

Both with the same result.

I thank you for your help.

My system :

Windows 8.1 Enterprise
Java Version 8 Update 211
Fiji 64bit 1.52o
i7-4790 (3.6 GHz)
16 GB RAM

On another system the story is exactly same:
Windows 7 Professional 64bit SP1
Java Version 8 Update 211
Fiji 64bit 1.52o
i5-4590 (3.3 GHz)
8 GB RAM

#4

Sorry, I still cannot reproduce this, I now tried on Windows 7 as well.

Could you please check that your Fiji is fully updated via Help > Update… (not Update ImageJ…) ?
Also, are there any third-party update sites enabled in your Fiji installation?

#5

I have no third-party update site.
I did Help/Update on the 1.52o version : µ is not displayed correctly
I downloaded again Fiji (1.52n), no update, no more plugin installed : µ is not displayed correctly
I executed again Fiji 1.52b : µ is displayed normally

really strange!

Thank you to try to help.

#6

I pushed a fix for this bug:

I’ll get it released within the next few days.

Of course, this is a separate issue from the µ display issue—which I also cannot reproduce on my macOS 10.14.4 system with ImageJ 2.0.0-rc-69/1.52o + Java 1.8.0_202.

1 Like
#7

Hello Tryphon (and Jan) -

Just to report another platform on which this works:

This works for me on both Fiji 1.52n and 1.52o*. Both the label
and description strings display the “µ” (mu, micron) properly. This
is running a bog-standard Fiji installation on ubuntu 16.04 LTS.

*) I had to run Help > Update ImageJ... to get to 1.52o.
Running Help > Update... leaves me at 1.52n. I’ve noticed
a number of recent posts mentioning 1.52o without further
comment, making me think it might be the “current” version.
Should I be expecting auto-update or Help > Update...
to be updating me to 1.52o, or is 1.52n still the official current
version?

Thanks, mm

#8

Hello,

Thank you for your comments and help. It becomes hard to point the issue origin. My machines are in my workplace. They are controlled by a security network support. Apart this I see nothing that could explain the ‘µ’ display issue.

I will install Fiji at home on my Ubuntu system (I do not have Windows at home). I let you know the result.

#9

The ImageJ update site still ships 1.52n, because we are in the process of transitioning some automation machinery to a different platform. But 1.52o is the most recently released version of ImageJ 1.x.

#10

The special character issue does not rise under Ubuntu 18 + Fiji 1.52o on my personal computer. Mystery remains under machines I use at workplace.

1 Like