[SOLVED] CP 3.0 on Linux cluster aborts with no helpful traceback

cellprofiler

#1

Hi,
I am trying to setup CP 3.0 on a Linux cluster in an Anaconda virtual env.
When I run a test script that tries to process a few images, the job aborts after a few seconds, but no helpful traceback is given:

$ ./test.sh 171208-SI0013-1
JVM will be started with AWT in headless mode
Creating JVM object
Signalling caller
Enabled Bio-formats directory cacheing
Number set to illegal value: 
Created temporary file /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5
/u/apahl/anaconda3/envs/cellprof/bin/cellprofiler: (11 <module>): load_entry_point('CellProfiler', 'console_scripts', 'cellprofiler')()
/draco/u/apahl/dev/github/CellProfiler/cellprofiler/__main__.py: (161 main): run_pipeline_headless(options, args)
/draco/u/apahl/dev/github/CellProfiler/cellprofiler/__main__.py: (738 run_pipeline_headless): initial_measurements=initial_measurements
/draco/u/apahl/dev/github/CellProfiler/cellprofiler/pipeline.py: (1558 run): copy=initial_measurements)
/draco/u/apahl/dev/github/CellProfiler/cellprofiler/measurement.py: (271 __init__): for frame in traceback.extract_stack():
HDF5Dict.__init__(): /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5, temporary=True, copy=None, mode=w
HDF5Dict.flush(): /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5, temporary=True
HDF5Dict.flush(): /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5, temporary=True
HDF5Dict.flush(): /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5, temporary=True
HDF5Dict.__del__(): /ptmp/apahl/cp/tmp/CpmeasurementswVHOJ1.hdf5, temporary=True

The script uses log level 10 (DEBUG).
Is there a possibility to get a more specific error message?
test.sh.txt (355 Bytes)

Many thanks in advance for your help.

Kind regards,
Axel


#2

Please ignore the above post, I made a mistake!!

KR Axel