SNT tracing through black pixels and not on neurite

Hello,
I have been tracing for a few days with no issues, and suddenly on one image the tracer decides to trace straight over black pixels, only following neurites that are very straight or if you click at very close intervals before finishing segment. Image attached. I


It does this on all images now so clearly some setting is different. I’ve looked through the settings and I’m really not sure what changed. Help getting this fixed much appreciated.

Hi @ihertzler , did this start occurring with the new release (3.1.113) last night?
I don’t believe that we changed any of the tracing-related code recently, so this seems odd.

1 Like

Odd indeed. Such ‘simple’ cell (drosophila da neuron?) should not be a source of any confusion for the program. Not so sure what could be the issue. If you suspect settings, you could run File→Reset and Restart… That will reset all preferences, and restart the program under defaults.

@arshadic it may well have occurred then, tracing was fine on the 24th and sometime during the day on the 25th it started doing that, although it didn’t seem to occur with an update/restart of imageJ, it was just image 9 traced fine and then image 10 the problem started. *(however this isn’t specific to image 10 - it now does it on any image).

@tferr I just tried a reset/restart of SNT and that did not fix it. (and it is a c4da neuron. Not my best example image ever).

I just tried reverting imageJ to v1.52 from 1.53h - to no avail. As with anything technological, I just did a fresh install of FIJI, added neuroanatomy to update sites and had it reinstall SNT, and the problem persists. I’m not sure how (if possible?) to install an older copy of SNT but that may be a thing to try.

@ihertzler, Wow, strange indeed. Sorry that things are that broken for you. You could try the following:

  1. The compiled artifacts of all released versions are always available online. You could try replacing the current version with its predecessor:

    1. Duplicate your complete Fiji.app directory, renaming it to something like Fiji-SNTdebup.app. This will ensure you will not brick your current installation.
    2. Locate the Fiji-SNTdebup.app/jars/ directory. There you will find a SNT_1.1.113.jar. Replace it with SNT-3.1.112.jar (direct download link) that was released late last year. If you need to revert, here is the download link for the current version: SNT-3.1.113.jar
    3. Try tracing your class IV cells with either jar version using Fiji-SNTdebup.app. This should clarify if the update is the culprit. Another thing to try is to trace on the demo images (in SNT: File→Choose Tracing Image→From Demo…): we did some quick testes with those images before releasing the current version and found everything to be working fine)
  2. If 1) does not solve things then please turn on Debug mode (Misc pane of Options tab) and see if the Console displays any relevant errors

  3. If none of the above was useful. Please attach here your image so that we can have a look

Thanks for the instructions on that, would not have known how to do that. I did that and replaced the jar with 3.1.112 (evidenced in the title bar of SNT, was correct) and the problem persists. However I think I may have found the problem. SNT seems to like 8 bit images and not 16 bit images. I guess it was in the middle of doing this genotype that I switched to 16 bit aquisition.
If you would like to try and confirm that is the case:
Here is 8 bit:010121-24hr-4 MIP.tif (976.8 KB)

Here is 16 bit:
021621-24hr-1 MIP.tif (1.9 MB)

If this is indeed the problem I can create an 8bit version of each image for tracing purposes.

@ihertzler, SNT parses 8-, 16-, and 32-bit images the same way and the date is cached internally when the image is loaded. Bit-depth should be irrelevant to any issues you are having.

One thing that could make a difference is if you are inverting your image somehow which you may not realize if, e.g., you are using and inverted LUT. That being said, I can trace your 16-bit image without issues on a ‘vanilla’ Fiji install. In this case, I have only clicked on soma and end-points:

At this point you could try the following:

  1. In Fiji, run Edit>Options>Reset… this will wipe all of IJ’s preferences which are shared across Fiji instances…

  2. If the problem persists, run the following as a python script in the script editor After starting opening and loading your problematic image in SNT. You can use SNT’s command Scripts>New… to do so. The script will only work while SNT is open:

#@SNTService snt
snt.getPlugin().getLoadedDataAsImp().show()

This will display the image exactly as snt cached it. When I ran it I got, unsurprisingly, an exact copy of the original image.

@ihertzler, I stand corrected. There seems to be an issue with dim dendrites indeed with 16-bit images but not 8-bit. I am not sure this can explain all the problems you are having but it is likely related. The ones I picked were just too bright. If I choose dimmer processes then I can see failures occurring. it could be a scaling issue. Will have to look.

@tferr I have noticed that some images/dendrites are brighter than others, and in these images, tracing can fail even on a dendrite I would deem “bright”, but not bright compared to the rest of them. The same thing happens in a dim image, an “especially dim” dendrite may cause a failure. Usually this isn’t too bad of a problem if you click shorter temp segments before reaching the tip. But it does in this particular case seem to be a 16 vs 8 bit issue. I am totally fine using 8 bit images for tracing purposes (I’ve been converting to 8 bit and tracing all day with no problems) so no worries if you don’t find anything.

@ihertzler, Please run the updater. This issue should now be fixed with the latest release, release notes.

It seems to be fixed, works great with 16 bit now. Thank you!