SNT: Problems with auto-snapping

Recently I’ve been using the Neuronatomy plugin on ImageJ/Fiji to analyze filtered images (.tif format). I’ve done all previous images (which I didn’t have issues with) on the same software, and same MacBook, which is a ~ 2018 model.

As of a couple weeks ago, whenever attempting to trace the .tif images on Neuronatomy, moving my mouse makes the frame switch while also moving the cursor, making it very difficult to accurately place endpoints. The shifting of frames does stop when I hold ‘shift’, but this is a nuisance and shouldn’t be happening - whenever I forget to hold it the frame shifts and I have to go back and find my place again.

I have tried:

  • Uploading multiple different images
  • Re downloading/uploading files
  • Using a plugin mouse instead of the touchpad
  • Going back to images I previously had no issues with

I experience the same problems while doing these, so I think the problem is because of an update. Does anyone have similar issue, or more experience with the software? I want to go back to a previous update but I’m not familiar enough with the program to know I’m doing this all correctly.

Thank you!
Happy Holidays
-Chandler

@CJCmcbucb , this is not a bug. Have a look at your cursor auto-snapping settings. When active and a Z-neighborhood is specified, SNT will continuously ‘sniff’ for signal around the cursor, thus moving the active Z-plane. You can disable auto-snapping in the Z-dimension by specifying 0 in the Z field (see snapshot below). You can also disable auto-snapping altogether by pressing S (note the highlighted letters in the several widgets: they report the corresponding keyboard shortcut).

Note then even with auto-snapping disabled it is still possible to automatically click on the brightest voxel above/below the cursor: Have a look at the contextual menu (displayed when right-clicking on the image canvas).

This is also expected, as holding-shift synchronizes all views.

On suitable images, auto-snapping can be quite useful if the snapping neighborhood is set right. For this reason, we decided to have it enabled by default. If people think it is too cumbersome to use, we could have it disabled by default.

2 Likes

Thank you so much for filling me in! This is exactly the issue I was having.

Best,
Chandler