SNT : issue with the UI

Hello @Tiago_Ferreira,

FIrst of all, thanks for the beautiful SNT plugin!
I have a few basic questions, I went through the documentation but I couldn’t find the answer:

  • is there a way to deactivate the mode ‘tracing of neurons’ ? Here’s my problem : when I’m done with the neuron tracing, I only want to use actions from the Path Manager (like refining), but I have a hard time doing this because my clicks in the image always trigger the creation of a new Path (while I just want to navigate in the image!)
  • related : is there a way to pan the image when it’s zoomed in ? I tried to select the hand in the FIJI interface, but it’s not working (the creation of new path is triggered instead, as described above)
  • is there a way to disable the ‘autofinding’ of the Z position when I’m hovering the mouse on the image ? Maybe I’m doing something wrong but it’s not so accurate
  • general : is there actually a way to perform a fully automated trace detection ? And then correcting this generated draft ?



Ok, this I found : I need to disable ‘Enable Snapping within:’

Right click : Pause SNT !

Well, it’s not ‘fully automated’ but I can reconstruct paths from a skeleton, as shown by this script ( And a skeleton (even if partly wrong), is pretty easy to generate.

Hi @NicoKiaru

On the skeleton, there is also a utility method in the main SNT GUI at Utilities > Reconstruction(s) from Skeleton… which is a more feature-rich version of the above script. It will load the generated skeleton(s) into the Path Manager and overlay them on the image, making it easier to curate the result. However, modifying the above script would provide the most flexibility.

1 Like

Glad you were able to find things out.

On the pan tool:
Holding the space bar should activate the hand tool and you should be able to pan the image canvas no matter the mode you are in. However, somehow it does not seem to be working in a reliable way. I opened an issue for it. Hopefully we can fix it soon (I must say everything is quite unusable without it).

On the “Auto-snapping” the cursor:
You should be able to toggle it at will by pressing its shortcut S (from “Enable _S_napping”). If you notice labels in the dialog have highlighted letters. Those highlight the key shortcut - No Ctrl/Cmd modifer required.

1 Like