SNT: Issue Tracing Multiple Cell Compartments

Hi there to all forum,
I’m facing some issues with SNT regarding calculation of some dendrites measuremets. I’ve roughly 100 picture that represent neurons. In each pictures multiple neurons are present.

From each neurons I want to trace different processes, length of dendrites and axons respectively. After annotating all the picture I want to run a script for getting the measurements for all the traced files I have.

The problem is that when I’ve multiple cells on the same trace there are problem in getting the measurements for the different compartments. I don’t understand what I’m doing wrong, and I’m starting to losing my mind.

image
image

when I click on Measure… and I select Distinguish Compartments I get this console error, for the same reason I get the same error also when I run the Batch Measurements script

java.lang.IllegalArgumentException: You can only select one connected set of paths for SWC export

The issue I think is related to some cell tracing, there are some missing path apparently but this is noticed only when I annotate the path with compartment informations. After that even if I remove annotation I get the same error. Other picture where I did not start this annotation work are quantified just fine…

@ddifraia, can you please upload the .traces file here? Please append a .txt extension to the filename otherwise the forum won’t allow the upload.

Hi Tiago, thanks a lot for your interest. Here is the traces:
example_traces_.txt (10.9 KB)

I have roughly 100 pics, so this is just an example. I guess there is a problem with recognising different cells, strange things is that if I run measures, on multiple attempt, sometimes it works (but tracing just some of the cells) and sometimes not, a little bit like a random behaviour. If I get the problem behind I could correct this for all the tracing that I have (which is a lot) it there is a way to overcome this with a script would be great!

Weird indeed. @ddifraia, we are having problems replicating this. When it works do you get a prompt similar to this one?
image

Yes, exactly. When it does not work, (randomly) seems to not get the correct number of cells. This is kind of a rule, so that, I can “predict” when is not going to work just based on the number of cells traced.

Also, if I annotate some other path, like basal dendrites or just soma for identify the cells, it never works.

Hi @ddifraia, this should be fixed in the latest release v3.1.111