Simple neurite tracer - 3D viewer

Hi everybody,

this is Ros and I am just approcching the Simple Neurite Tracer tool. I am working on a Surfece (as laptop from windows) and I am having troubles letting the software show me the 3D version of my stacks. I also tried with several other computers, also Apple, but I always got the same result that doesn’t make any sense.

Is there anything that I need to know specifically? I also updated Java.

Thanks in advance.
Ros

bumping this to @tferr

Welcome to the forum @Rosanna87!

Sorry you are having problems. but we’d need more details on what is exactly failing for you.

What exactly doesn’t make sense? It is virtually impossible to understand what is going wrong without more information. Here are a couple of suggestions:

  1. Ensure your Fiji installation is using Java8 and is up-to-date.
    See this wiki page for instructions. (If not, the easiest option might be to just download a new Fiji that comes bundled with Java 8). It is perfectly fine to have multiple Fiji installations installed.

  2. Subscribe to the NeuroAnatomy update site so that you can access the pre-release version of the software:
    1 . Run Help :arrow_forward: Update…
    2 . Click Manage update sites
    3 . Select the Neuroanatomy checkbox (see also list of update sites)
    4 . Click Apply changes and Restart ImageJ.

  3. Have a look at documentation of the Legacy 3D Viewer (which is what I’m assuming is failing for your: https://imagej.net/SNT:_Step-By-Step_Instructions#Tracing_in_the_Legacy_3D_Viewer

Do let us know how it goes!

Dear tferr,

I tryed to update the software, but I guess it already was. Anyway, it is still not working. I am try to run Plugins -> 3D viewer. But I am also trying with Plugin -> Segmentation -> Simple Neurite Traces and let it show the 3D view. What it gives me is like the object is between two mirrors. Please find attached the image that it builds.

Best

Ros
Error.png

I have no explanation for that image. But please do follow my suggestions above: You did not subscribe to the NeuroAnatomy update site: I know this because the menu structure to start SNT changes slightly from Plugins>Segmentation>Simple Neurite Tracer… to Plugins>NeuroAnatomy>SNT… after subscription. I also don’t think you followed the instructions at https://imagej.net/SNT:_Step-By-Step_Instructions#Tracing_in_the_Legacy_3D_Viewer: You shouldn’t run Plugins > 3D Viewer AND instantiate a 3D viewer from within SNT at the same time. That is likely to create conflicts between the two instances of the 3D Viewer.

At this point I strongly you suggest to start afresh, by downloading a new Fiji installation (you can rename it something like Fiji_SNT_Debug.app, and follow the instructions above. My guess is that the problem will go away, and once you have it working, we can always troubleshoot what is going wrong on your current installation.

Dear Tiago,

thansk a lot for your help but as you can see in this desk-picture, it is still not working. I directly downloded the newest version, plus i installed Neuroanatomy.