Sholl analysis (tracings) error

I’ve been using the Sholl analysis (tracings) function to analyse .swc files of neurite traces created in NeuronStudio.
Recently I’ve opened this to find an error message that the file selected is not a valid .swc file (although no file has yet been selected). When I do select the .swc files (which have worked fine in this program before), the error message remains and it is not possible to run the analysis (see image).

I’m running the most recent version of Fiji and have uninstalled and reinstalled it various times since the onset of this problem, but it hasn’t resolved.

Any ideas as to why this may be?

Welcome to the forum @mjjw!
Just to be clear: the path to the SWC file is valid? Ie, the file remains available when the dialog opened? What happens when you copy and paste the path from File explorer? does the error still occur? And this running Sholl Analysis v3.6.13 / Simple Neurite Tracer v3.1.4, correct?

Hi @tferr,

The error seems to occur regardless of where the file is located. The ‘browse’ button allows me to select the .swc file I want to analyse, however the ‘ok’ button becomes unclickable when I’ve done so and the error message remains.
Copying and pasting the path from file explorer has the same effect.

Also, if ‘load traces without images’ is unchecked, the error message also says the image file is invalid, regardless of whether an image file has been selected or not.

Yes, those are the versions I am running.


I think is just the same error reported while ago. Somehow it only occurs on Windows computers. See here for details:

I really though it was corrected. I will try to look into it (again) this week. Because it only affects the interactive use of the command, you could try to call the plugin from the Script Editor using the following macro:

//@File swcFile
run("Sholl Analysis (Tracings)...",
	"traces/(e)swc=[" + swcFile +"] load center=[Start of main path] "
	+ "radius=0  enclosing=1 infer linear polynomial=[Best fitting degree] "
	+ "most normalizer=Area/Volume ");

This would allow you to at least run the analysis under default settings until the issue is fixed. You can monitor the progress of the fix here:

1 Like

I tried on Windows and also get the Error: Not a valid .traces/.(e)swc file message after choosing a .traces file from my local disk. However, the message disappears as soon as I change any other parameter in the dialog (e.g. changing the drop-down option, or selecting and immediately deselecting the Include only paths … checkbox. After that, I was able to run the plugin as expected by clicking on OK.

Hi @imagejan,

Thanks for that, unfortunately that fix doesn’t seem to work for me.
(Have definitely tried changing all the potential parameters!)

Thank you!
Have downloaded the update with changes to simple neurite tracer and sholl analysis and it works fine now.

Glad it is working now. Just for future reference: I did not have enough time to truly debug the issue so the just released update does two things: 1) does a better job at ignoring repeated “” in the specified path [retrieving file paths through the 'Browse… button on Windows seems to do that at times – not sure why] and 2) the ‘OK’ button is no longer disabled when the path fails validity tests (If the path is indeed invalid an error will be thrown later on).