Sholl Analysis (Tracings)... Error

I have been running the Sholl analysis plugin on .traces files from simple neurite tracer (Analysis ▷ Sholl ▷ Sholl Analysis (Tracings)…). I have a macro set up to batch this process so I really need this plugin to work. This worked for quite a while and then I began getting this exception:

(Fiji Is Just) ImageJ 2.0.0-rc-59/1.51k; Java 1.8.0_66 [64-bit]; Mac OS X 10.11.6; 27MB of 2831MB (<1%)
	at java.util.Arrays.sort(
	at tracing.ShollAnalysisPlugin.guessInitialPaths(
	at tracing.ShollAnalysisPlugin.showDialog(
	at ij.IJ.runUserPlugIn(
	at ij.IJ.runPlugIn(
	at ij.Executer.runCommand(

I’ve tried updating fiji, reinstalling fiji, reinstalling java 8, installing an older version of fiji, using older version of the sholl analysis and simple neurite tracer plugins. Sometimes I can get it to work again for a while on a different computer but inevitably eventually I get the same exception and can’t overcome it. Any help would be greatly appreciated!

Hi Thomas. Welcome to the forum!

Really sorry you are having problems. When you specify a file in the Traces/(e)SWC file field, the plugin makes a list of all the files found on the directory where the specified file resides, and uses it to automatically populate (by educated guess) the Image file field below in the prompt.

I haven’t looked into it yet, but in your case, it seems as if the plugin is not detecting .traces files in the path you have specified. A couple of reasons could be: files have unexpected extensions, are seen as hidden, or perhaps are in a remote server? Is any of these the case?

That being said, this is just a convenience feature (almost UI gimmickry). It does not need to be used when calling the plugin from a macro. We could try to debug it, or I could just disable it when the plugin is being called by a macro or script. Would that be OK for you?

You can monitor the progress on this issue here. I will try to look into it quickly.


@tbastian, Please run the updater: this issue should be fixed in the just-released v3.1.1. Do let us know how it goes on your end.


It looks like that did the trick! Thank you very much!

1 Like