Sholl analysis java.lang.NullPointerException

Hello everyone,

I’ve been performing sholl analyses on images of traced astrocytes in ImageJ. It worked perfectly for a while, but now I keep getting an error of some sort. I’ve attached a screenshot of the log.
I’ve tried to analyse different pictures that used to work before, but I get the same result.

Do any of you happen to know what the problem might be? Help would be greatly appreciated.
I’ve also attatched one of my images if that might be useful. Reinstalling the program has not helped.

Thanks in advance. :slight_smile:

Schermafbeelding 2020-04-30 om 13.41.34

Welcome to the forum @mikheikamp!

The error seems to indicate the defined radii were invalid.

That is a very vague description, so it is hard to know what the problem could be. The plugin reads foreground/background, and voxel size on an image-per-image-basis. Thus, I would encourage you to look closely at the image metadata: E.g., did the spatial calibration change? Do segmented voxels have a value of 0? Have a look at the documentation at imagej.net/Sholl for more information on these.

For what is worth it, I took your snapshot and analyzed it without problems: