Set scale z-stack inches to um

Hi everyone,

this is Ros. I’m having troubles with an image (z-stack) that I didn’t collect and when I open it in Fiji, it turns out to be in inches. I tried to ask for the micron / pixel and the only info I have at the moment are the following that derive from the photo itself:
slice number
pixel width 0.0033333
pixel height 0.0033333
Volxel depth 1.0
Frame interval 0 sec
Origin 0.0
At the end the photo is large 5.33 x 4 inches that I don’t think are real measurements considering that they correspond to about 12 x 10 cm … since we are talking about dendrites, I don’t find it possible.

What I know I would like the software to know is that:
Images are acquired every 1 micron
voxel size is 0.185 um

I tried to convert these micron to inches and to replace at least these two values, but it doesn’t change the detail of the image’s size. Moreover, every time I do this process, the Simple Neurite Tracer tool no longer works well and tracks unreal things.
Can you help me?

Thanks
Ros

@Rosanna87
Can you share with us an original image file to double-check your Image Properties?

But let’s start with:

  1. How are you opening your images? I’d recommend using Bio-Formats to import them - to be sure metadata is read in correctly.
  2. When you say:

What do you mean exactly? How exactly did you try to alter the scale/properties of your image? Just double-check our page on Spatial Calibration to be sure the methods you are using are correct…

Once we know this… we can move on the SNT issues.

Dear Ellen,

I am sorry, but I am not allowed to share the image. Anyway, attached you can find the screedshot containing the original image properties.

I guess that the image has the calibration of the microscope from witch it derives. But, even if I have inches in the original format, I was trying to assigne it the voxel and the z-step in Analyse -> Set scale; it is not collaborating. And just to add one more problem, when I try this procedure the Neuron traces doesn’t perform as it should.

Are helpful the information I gave?

Thanks

Ros

@Rosanna87

Again - how are you opening your images? Try using Bio-Formats as I suggested before… and read through those links I provided in my previous message.

You should be able to set the voxel depth via Images>Properties directly. There you can manually set the pixel xyz to the correct proportion and unit.

Dear Ellen,

sorry I gave you no update, but I tried and tried again without success. I was able to get the authorization to send you an image with which I have not only the problem of scale, but also the problem of not being able to perform 3D reconstruction. Can I still attach the image?

Thank you very much for you help.
Rosanna

@Rosanna87

Sure - attach the image. Perhaps others here can help as well?

Please, find attached the image to try.
Copy.tif

@Rosanna87

If I open your image via Bio-Formats (suggested above)… so File > Import > Bio-Formats - I get calibrations microns. Not sure if they are accurate - but you can test and see yourself.

Dear Ellen,

thanks for this advice. I did it and actually it works. One less problem!!!

Unfortunatelly, the measurement are not accurate at all. The point is that, regarding these images, I have to be able to tell the program that the images are acquired every 1 micron (z-stacks) and that the voxel size is 0.185 um. I have to trace that neuron and measure the lenght of its branches (I am doing it with neurona traces tool). As it is now set, my images says that my neurons are large cm, when it is impossible. How can procede about giving it the real scale?
Is this info (1 micron (z-stacks) and that the voxel size is 0.185 um) enough for me or do I need anything else? In Analysis - Tool- Set scale, for example, it doesn’t let me put voxels.

Please, let me know if you need any other information to help me get to the solution.

Thank you for your prescious help.
Rosanna

@Rosanna87

You can change the voxel size via the menu Image -> Properties….