Secondary object over segmentation

[membrance.tiff|attachment] I use Identifysecondaryobject to segmentation the nuclei, but it is over-segmentation, many nucleis are splited. How can I deal with it? Thank you.

I use Image J.
Maybe this macro would help you!

Segmentation1-1

//setTool("rectangle");
makeRectangle(320, 168, 624, 440);
run("Crop");
run("Duplicate...", "title=1");
close("\\Others");
run("Duplicate...", "title=2");
roiManager("Show All");
setAutoThreshold("RenyiEntropy dark");
run("Convert to Mask");
run("Watershed");
run("Set Measurements...", "area mean add redirect=None decimal=0");
run("Analyze Particles...", "display exclude add");
selectWindow("1");
roiManager("Show All without labels");

Greetings

Hi @minghlijiyi,

To segment the Nuclei you can use “IdentifyPrimaryObject” module & to sement the cells using your nuclei information you can use “IdentifySecondaryObject” module. Here is the screenshot of your nuclei segmentation with the basic parameters setting just by changing the object size.

Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
For CellProfiler training or optimised pipeline write to,
lakshmi.balasubramanian.contractor@fujifilm.com

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

Hi Lakshmi,
Thank you for your help. I try your parameter, fewer cells are over-segmentation, but it still happens. Could you give more suggestion?


Thank you so much!

Hi @minghlijiyi,

Over-segmentation is largely going to be caused by the declumping settings towards the bottom of the IdentifyPrimaryObjects module. Try increasing the declumping smoothing filter size and the minimum distance between local maxima.

Hope that helps!

Thank you for your suggestion. I try the declumping smoothing filter size and the minimum local maxima set as 2, but it still over-segmentation.

.

I add “Smooth” module before the “IdentifyPrimaryObject”, and use your shared parameter value, it works good now, thank you for your help!

Hi @minghlijiyi,
Great!!!
you are welcome!!

Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
For CellProfiler training or optimised pipeline write to,
lakshmi.balasubramanian.contractor@fujifilm.com

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

I’m glad that this is solved, but for future reference the filter sizes are in pixels. A minimum distance between maxima of 2 pixels may be too small for the images you’re using. Perhaps try in the range of 5-10 if you’re still optimising this. The same applies to the smoothing filter.

Which FIJI plugin did you use to segment the cells and nuclei? Thank you.