Sciview makes fiji crash

Hello!

I have never used Sciview before, but I wanted to give it a try with my .obj files. Only, fiji does not open it at all, rather it crashes without displaying any error whatsoever on the console.
Could anyone please enlighten me?

2 Likes

Yes, me also and have had this problem for quite a while.
Bob

1 Like

A couple of vthings that would be to very useful to do: 1) ensure your Fiji installation subscribed to the SciView update site is really up-to-date and 2) produce a debug log, by starting Fiji from the command line and specify -Dscenery.LogLevel=debug.
Pinging @kephale @skalarproduktraum, who can probably help

4 Likes

@tweagles1 and @smith_robertj

Building on Tiago’s comment, could you tell us:

  1. what operating system are you using?
  2. is SciView up-to-date?
  3. can you specify what you are doing when it crashes? (e.g., Open Fiji then click Plugins>SciView, or does it get further than that?)
  4. if you start Fiji from the command line, then could you add -Dscenery.LogLevel=debug and send the debug log
3 Likes

Thanks for the replies.

  1. Personally, I am working on a Windows 10 (no clue whether it is the case for @smith_robertj as well or not of course)
  2. No further update is available for Sciview
  3. It does not go any further than that indeed. I just open the plugin, Sciview starts being opened (meaning I see “Scenery Sciview” and the version), then it immediately crashes.
  4. I would do this since I see it would be helpful. Only, I don’t know how to start FIji from the command line…

Here is a guide:

Thanks for the new tip.
Attached here
hs_err_pid6388.txt (35.6 KB)
is the report I get

2 Likes

@tweagles1 Thanks.

Might be similar to this issue. You could try:

  1. Upgrading (or downgrading!) your graphics drivers, esp. Vulkan drivers(?).
  2. Using a different graphics card and/or machine.
  3. Hoping that @skalarproduktraum has more sensible and useful advice, and/or a magical fix. :mage::crystal_ball::sparkles:

@tweagles1

What graphics card/driver are you using (including driver version)?
If it is a Nvidia card/driver, then this might help for reporting the version https://nvidia.custhelp.com/app/answers/detail/a_id/2039/~/how-do-i-determine-which-nvidia-display-driver-version-is-currently-installed

1 Like

Hey @tweagles1,

thanks for the log file. It seems you are using an Intel Integrated GPU. Could you try and see if there are some more up-to-date drivers for that one? There have been some pretty serious bugs in older versions of them, and this looks like one of them. Also, if you could post the output of Fiji, that’d be very helpful :+1:

For a temporary workaround, you can run Fiji from the command line with the additional parameter -Dscenery.Renderer=OpenGLRenderer, which forces it to use the fallback renderer.

Edit: Intel actually has this Driver Advisor thingy, https://www.intel.com/content/www/us/en/support/detect.html, maybe this can help you find the best version for your hardware :+1:

2 Likes

I have updated everything according to what is written there.

The main difference is that it is sufficient to finally open Sciview. What is mesmerizing to me is that I can get different outcomes from doing the exact same things. That is:

With an updated hardware at least I can open Sciview (sometimes), but I still report everything I get, maybe it is helpful…

3 Likes

Thank you for your thoroughness! It is much appreciated!